CVE-2021-32671 XSS vulnerability with translator
Attackers can inject malicious HTML into user inputs, leading to script execution and potential account takeover or admin privilege abuse.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2021-32671?
CVE-2021-32671 is a critical cross-site scripting vulnerability in flarum core, published on 7 Jun 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Flarum is a forum software for building communities. Flarum's translation system allowed for string inputs to be converted into HTML DOM nodes when rendered. This change was made after v0.1.0-beta.16 (our last beta before v1.0.0) and was not noticed or documented. This allowed for any user to type malicious HTML markup within certain user input fields and have this execute on client browsers. The example which led to the discovery of this vulnerability was in the forum search box. Entering faux-malicious HTML markup, such as <script>alert('test')</script> resulted in an alert box appearing on the forum. This attack could also be modified to perform AJAX requests on behalf of a user, possibly deleting discussions, modifying their settings or profile, or even modifying settings on the Admin panel if the attack was targetted towards a privileged user. All Flarum communities that run flarum v1.0.0 or v1.0.1 are impacted. The vulnerability has been fixed and published as flarum/core v1.0.2. All communities running Flarum v1.0 have to upgrade as soon as possible to v1.0.2.
Weakness: CWE-79
Which versions are affected by CVE-2021-32671?
2 open source packages ship an affected version, including flarum/core. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
flarum/core Packagist | From 1.0.0 | 1.0.2 |
flarum/core Packagist | From 1.0.0 | 1.0.2 |
Products include Flarum Flarum.
How do I fix CVE-2021-32671?
Upgrade flarum/core to 1.0.2 or later.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2021-32671 being exploited?
There is no known exploitation of CVE-2021-32671 in the wild and no public exploit code.
Other vulnerabilities in flarum core
- CVE-2022-41938 Cross site scripting vulnerability with discussion titles in flarum
- CVE-2019-13183 Cross-site request forgery in n/a
- CVE-2023-22487 Post mentions can be used to read any post on the forum without access control
- CVE-2019-11514 Flarum mishandles invalidation of user email tokens
- CVE-2023-40033 Server-Side Request Forgery via Avatar upload in flarum
Sources
Also known as GHSA-5qjq-69w6-fg57.