{"answers":{"affected":"2 open source packages ship an affected version, including flarum/core. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-32671 in the wild and no public exploit code.","fix":"Upgrade flarum/core to 1.0.2 or later.","what":"CVE-2021-32671 is a critical cross-site scripting vulnerability in flarum core, published on 7 Jun 2021. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2021-32671 and fix it if it is affected.\n\nWhat it is: CVE-2021-32671 is a critical cross-site scripting vulnerability in flarum core, published on 7 Jun 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2021-32671 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- flarum/core (Packagist): affected from 1.0.0; fixed in 1.0.2\n- flarum/core (Packagist): affected from 1.0.0; fixed in 1.0.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-32671/ (Markdown: https://insights.sbomify.com/CVE-2021-32671/index.md)","id":"CVE-2021-32671","markdown":"https://insights.sbomify.com/CVE-2021-32671/index.md","name":"CVE-2021-32671","record":{"aliases":["GHSA-5qjq-69w6-fg57"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Flarum forum software","requires_auth":"none","summary":"Attackers can inject malicious HTML into user inputs, leading to script execution and potential account takeover or admin privilege abuse.","user_interaction":"not_required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"flarum","vendor":"flarum"}],"cvss":{"score":10,"severity":"critical","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Flarum is a forum software for building communities. Flarum's translation system allowed for string inputs to be converted into HTML DOM nodes when rendered. This change was made after v0.1.0-beta.16 (our last beta before v1.0.0) and was not noticed or documented. This allowed for any user to type malicious HTML markup within certain user input fields and have this execute on client browsers. The example which led to the discovery of this vulnerability was in the forum search box. Entering faux-malicious HTML markup, such as \u003cscript\u003ealert('test')\u003c/script\u003e resulted in an alert box appearing on the forum. This attack could also be modified to perform AJAX requests on behalf of a user, possibly deleting discussions, modifying their settings or profile, or even modifying settings on the Admin panel if the attack was targetted towards a privileged user. All Flarum communities that run flarum v1.0.0 or v1.0.1 are impacted. The vulnerability has been fixed and published as flarum/core v1.0.2. All communities running Flarum v1.0 have to upgrade as soon as possible to v1.0.2.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"XSS vulnerability with translator","id":"CVE-2021-32671","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2021"},"n_packages":2,"n_references":3,"next":{"headline":"Vulnerability in Lua Debugger in Redis","id":"CVE-2021-32672"},"packages":[{"ecosystem":"Packagist","fixed":["1.0.2"],"introduced":["1.0.0"],"last_affected":[],"package":"flarum/core","purl":null,"source":"GHSA-5qjq-69w6-fg57"},{"ecosystem":"Packagist","fixed":["1.0.2"],"introduced":["1.0.0"],"last_affected":[],"package":"flarum/core","purl":"pkg:composer/flarum/core","source":"GHSA-5qjq-69w6-fg57"}],"prev":{"headline":"Reflected cross-site scripting issue in Datasette","id":"CVE-2021-32670"},"products":["core"],"published":"2021-06-07","related":[{"cvss_score":9,"headline":"Cross site scripting vulnerability with discussion titles in flarum","id":"CVE-2022-41938","kev_date_added":null,"published":"2022-11-19"},{"cvss_score":8.8,"headline":"Cross-site request forgery in n/a","id":"CVE-2019-13183","kev_date_added":null,"published":"2019-07-07"},{"cvss_score":7.7,"headline":"Post mentions can be used to read any post on the forum without access control","id":"CVE-2023-22487","kev_date_added":null,"published":"2023-01-11"},{"cvss_score":7.5,"headline":"Flarum mishandles invalidation of user email tokens","id":"CVE-2019-11514","kev_date_added":null,"published":"2019-04-25"},{"cvss_score":7.1,"headline":"Server-Side Request Forgery via Avatar upload in flarum","id":"CVE-2023-40033","kev_date_added":null,"published":"2023-08-16"},{"cvss_score":6.8,"headline":"Flarum Vulnerable to Session Hijacking via Authoritative Subdomain Cookie Overwrite","id":"CVE-2025-27794","kev_date_added":null,"published":"2025-03-12"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["flarum"]},"summary":"Attackers can inject malicious HTML into user inputs, leading to script execution and potential account takeover or admin privilege abuse.","url":"https://insights.sbomify.com/CVE-2021-32671/"}