# CVE-2021-32671: XSS vulnerability with translator

> Attackers can inject malicious HTML into user inputs, leading to script execution and potential account takeover or admin privilege abuse.

- **Severity:** Critical 10.0 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Jun 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-5qjq-69w6-fg57

## What is CVE-2021-32671?

CVE-2021-32671 is a critical cross-site scripting vulnerability in flarum core, published on 7 Jun 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Flarum is a forum software for building communities. Flarum's translation system allowed for string inputs to be converted into HTML DOM nodes when rendered. This change was made after v0.1.0-beta.16 (our last beta before v1.0.0) and was not noticed or documented. This allowed for any user to type malicious HTML markup within certain user input fields and have this execute on client browsers. The example which led to the discovery of this vulnerability was in the forum search box. Entering faux-malicious HTML markup, such as <script>alert('test')</script> resulted in an alert box appearing on the forum. This attack could also be modified to perform AJAX requests on behalf of a user, possibly deleting discussions, modifying their settings or profile, or even modifying settings on the Admin panel if the attack was targetted towards a privileged user. All Flarum communities that run flarum v1.0.0 or v1.0.1 are impacted. The vulnerability has been fixed and published as flarum/core v1.0.2. All communities running Flarum v1.0 have to upgrade as soon as possible to v1.0.2.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2021-32671?

2 open source packages ship an affected version, including flarum/core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `flarum/core` | Packagist | From 1.0.0 | 1.0.2 |
| `flarum/core` | Packagist | From 1.0.0 | 1.0.2 |

Products: Flarum Flarum.

## How do I fix CVE-2021-32671?

Upgrade flarum/core to 1.0.2 or later.

## Is CVE-2021-32671 being exploited?

There is no known exploitation of CVE-2021-32671 in the wild and no public exploit code.

## Other vulnerabilities in flarum core

- [CVE-2022-41938](https://insights.sbomify.com/CVE-2022-41938/): Cross site scripting vulnerability with discussion titles in flarum (critical 9.0)
- [CVE-2019-13183](https://insights.sbomify.com/CVE-2019-13183/): Cross-site request forgery in n/a (high 8.8)
- [CVE-2023-22487](https://insights.sbomify.com/CVE-2023-22487/): Post mentions can be used to read any post on the forum without access control (high 7.7)
- [CVE-2019-11514](https://insights.sbomify.com/CVE-2019-11514/): Flarum mishandles invalidation of user email tokens (high 7.5)
- [CVE-2023-40033](https://insights.sbomify.com/CVE-2023-40033/): Server-Side Request Forgery via Avatar upload in flarum (high 7.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-32671 and fix it if it is affected.

What it is: CVE-2021-32671 is a critical cross-site scripting vulnerability in flarum core, published on 7 Jun 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-32671 in the wild and no public exploit code.

Affected packages and fixed versions:
- flarum/core (Packagist): affected from 1.0.0; fixed in 1.0.2
- flarum/core (Packagist): affected from 1.0.0; fixed in 1.0.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-32671/ (Markdown: https://insights.sbomify.com/CVE-2021-32671/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-32671
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-32671
- OSV: https://osv.dev/vulnerability/CVE-2021-32671

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-32671/
Summaries are generated and may contain mistakes; the official description above is the record.
