{"answers":{"affected":"2 open source packages ship an affected version, including reg-keygen-git-hash-plugin. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-32673 in the wild and no public exploit code.","fix":"Upgrade reg-keygen-git-hash-plugin to 0.10.16 or later.","what":"CVE-2021-32673 is a high-severity command injection vulnerability in reg-viz reg-suit, published on 8 Jun 2021. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2021-32673 and fix it if it is affected.\n\nWhat it is: CVE-2021-32673 is a high-severity command injection vulnerability in reg-viz reg-suit, published on 8 Jun 2021. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2021-32673 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- reg-keygen-git-hash-plugin (npm): affected all versions; fixed in 0.10.16\n- reg-keygen-git-hash-plugin (npm): affected all versions; fixed in 0.10.16\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-32673/ (Markdown: https://insights.sbomify.com/CVE-2021-32673/index.md)","id":"CVE-2021-32673","markdown":"https://insights.sbomify.com/CVE-2021-32673/index.md","name":"CVE-2021-32673","record":{"aliases":["GHSA-49q3-8867-5wmp"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"npm plugin","requires_auth":"none","summary":"Remote attackers can execute arbitrary commands via the reg-keygen-git-hash-plugin, requiring an upgrade to the latest version.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"reg-keygen-git-hash","vendor":"reg-keygen-git-hash_project"}],"cvss":{"score":8.8,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:C/C:H/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-78","name":"Improper Neutralization of Special Elements used in an OS Command"},{"id":"CWE-94","name":"Improper Control of Generation of Code"}],"description":"reg-keygen-git-hash-plugin is a reg-suit plugin to detect the snapshot key to be compare with using Git commit hash. reg-keygen-git-hash-plugin through and including 0.10.15 allow remote attackers to execute of arbitrary commands. Upgrade to version 0.10.16 or later to resolve this issue.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Remote Command Execution in reg-keygen-git-hash-plugin","id":"CVE-2021-32673","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"command_injection","year":"2021"},"n_packages":2,"n_references":4,"next":{"headline":"Remote Code Execution via traversal in TAL expressions","id":"CVE-2021-32674"},"packages":[{"ecosystem":"npm","fixed":["0.10.16"],"introduced":["0"],"last_affected":[],"package":"reg-keygen-git-hash-plugin","purl":null,"source":"GHSA-49q3-8867-5wmp"},{"ecosystem":"npm","fixed":["0.10.16"],"introduced":["0"],"last_affected":[],"package":"reg-keygen-git-hash-plugin","purl":"pkg:npm/reg-keygen-git-hash-plugin","source":"GHSA-49q3-8867-5wmp"}],"prev":{"headline":"Vulnerability in Lua Debugger in Redis","id":"CVE-2021-32672"},"products":["reg-suit"],"published":"2021-06-08","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["reg-viz"]},"summary":"Remote attackers can execute arbitrary commands via the reg-keygen-git-hash-plugin, requiring an upgrade to the latest version.","url":"https://insights.sbomify.com/CVE-2021-32673/"}