# CVE-2021-32673: Remote Command Execution in reg-keygen-git-hash-plugin

> Remote attackers can execute arbitrary commands via the reg-keygen-git-hash-plugin, requiring an upgrade to the latest version.

- **Severity:** High 8.8 (`CVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:C/C:H/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Jun 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-49q3-8867-5wmp

## What is CVE-2021-32673?

CVE-2021-32673 is a high-severity command injection vulnerability in reg-viz reg-suit, published on 8 Jun 2021. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

reg-keygen-git-hash-plugin is a reg-suit plugin to detect the snapshot key to be compare with using Git commit hash. reg-keygen-git-hash-plugin through and including 0.10.15 allow remote attackers to execute of arbitrary commands. Upgrade to version 0.10.16 or later to resolve this issue.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command), CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2021-32673?

2 open source packages ship an affected version, including reg-keygen-git-hash-plugin. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `reg-keygen-git-hash-plugin` | npm | All versions | 0.10.16 |
| `reg-keygen-git-hash-plugin` | npm | All versions | 0.10.16 |

Products: Reg-Keygen-Git-Hash Project Reg-Keygen-Git-Hash.

## How do I fix CVE-2021-32673?

Upgrade reg-keygen-git-hash-plugin to 0.10.16 or later.

## Is CVE-2021-32673 being exploited?

There is no known exploitation of CVE-2021-32673 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-32673 and fix it if it is affected.

What it is: CVE-2021-32673 is a high-severity command injection vulnerability in reg-viz reg-suit, published on 8 Jun 2021. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-32673 in the wild and no public exploit code.

Affected packages and fixed versions:
- reg-keygen-git-hash-plugin (npm): affected all versions; fixed in 0.10.16
- reg-keygen-git-hash-plugin (npm): affected all versions; fixed in 0.10.16

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-32673/ (Markdown: https://insights.sbomify.com/CVE-2021-32673/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-32673
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-32673
- OSV: https://osv.dev/vulnerability/CVE-2021-32673

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-32673/
Summaries are generated and may contain mistakes; the official description above is the record.
