{"answers":{"affected":"3 open source packages ship an affected version, including fastapi. It affects 2 products.","exploited":"There is no known exploitation of CVE-2021-32677 in the wild and no public exploit code.","fix":"Upgrade fastapi to 0.65.2 or later.","what":"CVE-2021-32677 is a high-severity vulnerability in Fedoraproject Fedora, published on 9 Jun 2021. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2021-32677 and fix it if it is affected.\n\nWhat it is: CVE-2021-32677 is a high-severity vulnerability in Fedoraproject Fedora, published on 9 Jun 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2021-32677 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- fastapi (PyPI): affected all versions; fixed in 0.65.2\n- fastapi (PyPI): affected all versions; fixed in 0.65.2\n- fastapi (PyPI): affected all versions; fixed in 0.65.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-32677/ (Markdown: https://insights.sbomify.com/CVE-2021-32677/index.md)","id":"CVE-2021-32677","markdown":"https://insights.sbomify.com/CVE-2021-32677/index.md","name":"CVE-2021-32677","record":{"aliases":["CLSA-2025-1754957513","DEBIAN-CVE-2021-32677","GHSA-8h2j-cgx8-6xv7","PYSEC-2021-100","UBUNTU-CVE-2021-32677"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["account_takeover","data_modify"],"network_reachable":"yes","non_default_config":true,"product_category":"Python web framework","requires_auth":"none","summary":"Attackers can perform CSRF attacks against FastAPI applications using cookie-based authentication by sending JSON payloads with text/plain content types.","user_interaction":"not_required","vuln_class":"csrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"fedora","vendor":"fedoraproject"},{"product":"fastapi","vendor":"tiangolo"}],"cvss":{"score":8.2,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-352","name":"Cross-Site Request Forgery"}],"description":"FastAPI is a web framework for building APIs with Python 3.6+ based on standard Python type hints. FastAPI versions lower than 0.65.2 that used cookies for authentication in path operations that received JSON payloads sent by browsers were vulnerable to a Cross-Site Request Forgery (CSRF) attack. In versions lower than 0.65.2, FastAPI would try to read the request payload as JSON even if the content-type header sent was not set to application/json or a compatible JSON media type (e.g. application/geo+json). A request with a content type of text/plain containing JSON data would be accepted and the JSON data would be extracted. Requests with content type text/plain are exempt from CORS preflights, for being considered Simple requests. The browser will execute them right away including cookies, and the text content could be a JSON string that would be parsed and accepted by the FastAPI application. This is fixed in FastAPI 0.65.2. The request data is now parsed as JSON only if the content-type header is application/json or another JSON compatible media type like application/geo+json. It's best to upgrade to the latest FastAPI, but if updating is not possible then a middleware or a dependency that checks the content-type header and aborts the request if it is not application/json or another JSON compatible content type can act as a mitigating workaround.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Cross-Site Request Forgery (CSRF) in FastAPI","id":"CVE-2021-32677","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":"fedoraproject:fedora","products":["fedoraproject:fedora"],"type":"csrf","year":"2021"},"n_packages":3,"n_references":3,"next":{"headline":"Ratelimit not applied on OCS API responses","id":"CVE-2021-32678"},"packages":[{"ecosystem":"PyPI","fixed":["0.65.2"],"introduced":["0"],"last_affected":[],"package":"fastapi","purl":null,"source":"GHSA-8h2j-cgx8-6xv7"},{"ecosystem":"PyPI","fixed":["0.65.2"],"introduced":["0"],"last_affected":[],"package":"fastapi","purl":"pkg:pypi/fastapi","source":"GHSA-8h2j-cgx8-6xv7"},{"ecosystem":"PyPI","fixed":["0.65.2"],"introduced":["0"],"last_affected":[],"package":"fastapi","purl":"pkg:pypi/fastapi","source":"PYSEC-2021-100"}],"prev":{"headline":"Session Fixation in Nextcloud Talk","id":"CVE-2021-32676"},"products":["fastapi"],"published":"2021-06-09","related":[{"cvss_score":9.8,"headline":"PHP-CGI OS Command Injection","id":"CVE-2024-4577","kev_date_added":"2024-06-12","published":"2024-06-09"},{"cvss_score":9.8,"headline":"Grafana Authentication Bypass","id":"CVE-2021-39226","kev_date_added":"2022-08-25","published":"2021-10-05"},{"cvss_score":9.8,"headline":"VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow","id":"CVE-2019-5544","kev_date_added":"2021-11-03","published":"2019-12-06"},{"cvss_score":9.6,"headline":"Google Chromium V8 Type Confusion","id":"CVE-2024-4947","kev_date_added":"2024-05-20","published":"2024-05-15"},{"cvss_score":9.6,"headline":"Google Chromium Visuals Use-After-Free","id":"CVE-2024-4671","kev_date_added":"2024-05-13","published":"2024-05-09"},{"cvss_score":9.6,"headline":"Google Chromium Mojo Insufficient Data Validation","id":"CVE-2022-3075","kev_date_added":"2022-09-08","published":"2022-09-26"},{"cvss_score":9.6,"headline":"Google Chromium Indexed DB API Use-After-Free","id":"CVE-2021-30633","kev_date_added":"2021-11-03","published":"2021-10-08"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["tiangolo"]},"summary":"Attackers can perform CSRF attacks against FastAPI applications using cookie-based authentication by sending JSON payloads with text/plain content types.","url":"https://insights.sbomify.com/CVE-2021-32677/"}