# CVE-2021-32677: Cross-Site Request Forgery (CSRF) in FastAPI

> Attackers can perform CSRF attacks against FastAPI applications using cookie-based authentication by sending JSON payloads with text/plain content types.

- **Severity:** High 8.2 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Jun 2021
- **Updated:** 3 Aug 2024
- **Also known as:** CLSA-2025-1754957513, DEBIAN-CVE-2021-32677, GHSA-8h2j-cgx8-6xv7, PYSEC-2021-100, UBUNTU-CVE-2021-32677

## What is CVE-2021-32677?

CVE-2021-32677 is a high-severity vulnerability in Fedoraproject Fedora, published on 9 Jun 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

FastAPI is a web framework for building APIs with Python 3.6+ based on standard Python type hints. FastAPI versions lower than 0.65.2 that used cookies for authentication in path operations that received JSON payloads sent by browsers were vulnerable to a Cross-Site Request Forgery (CSRF) attack. In versions lower than 0.65.2, FastAPI would try to read the request payload as JSON even if the content-type header sent was not set to application/json or a compatible JSON media type (e.g. application/geo+json). A request with a content type of text/plain containing JSON data would be accepted and the JSON data would be extracted. Requests with content type text/plain are exempt from CORS preflights, for being considered Simple requests. The browser will execute them right away including cookies, and the text content could be a JSON string that would be parsed and accepted by the FastAPI application. This is fixed in FastAPI 0.65.2. The request data is now parsed as JSON only if the content-type header is application/json or another JSON compatible media type like application/geo+json. It's best to upgrade to the latest FastAPI, but if updating is not possible then a middleware or a dependency that checks the content-type header and aborts the request if it is not application/json or another JSON compatible content type can act as a mitigating workaround.

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2021-32677?

3 open source packages ship an affected version, including fastapi. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `fastapi` | PyPI | All versions | 0.65.2 |
| `fastapi` | PyPI | All versions | 0.65.2 |
| `fastapi` | PyPI | All versions | 0.65.2 |

Products: Fedoraproject Fedora, Tiangolo Fastapi.

## How do I fix CVE-2021-32677?

Upgrade fastapi to 0.65.2 or later.

## Is CVE-2021-32677 being exploited?

There is no known exploitation of CVE-2021-32677 in the wild and no public exploit code.

## Other vulnerabilities in Fedoraproject Fedora

- [CVE-2024-4577](https://insights.sbomify.com/CVE-2024-4577/): PHP-CGI OS Command Injection (critical 9.8, exploited in the wild)
- [CVE-2021-39226](https://insights.sbomify.com/CVE-2021-39226/): Grafana Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2019-5544](https://insights.sbomify.com/CVE-2019-5544/): VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2024-4947](https://insights.sbomify.com/CVE-2024-4947/): Google Chromium V8 Type Confusion (critical 9.6, exploited in the wild)
- [CVE-2024-4671](https://insights.sbomify.com/CVE-2024-4671/): Google Chromium Visuals Use-After-Free (critical 9.6, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-32677 and fix it if it is affected.

What it is: CVE-2021-32677 is a high-severity vulnerability in Fedoraproject Fedora, published on 9 Jun 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-32677 in the wild and no public exploit code.

Affected packages and fixed versions:
- fastapi (PyPI): affected all versions; fixed in 0.65.2
- fastapi (PyPI): affected all versions; fixed in 0.65.2
- fastapi (PyPI): affected all versions; fixed in 0.65.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-32677/ (Markdown: https://insights.sbomify.com/CVE-2021-32677/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-32677
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-32677
- OSV: https://osv.dev/vulnerability/CVE-2021-32677

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-32677/
Summaries are generated and may contain mistakes; the official description above is the record.
