{"answers":{"affected":"It affects 2 products.","exploited":"There is no known exploitation of CVE-2021-32678 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2021-32678 is a low-severity vulnerability in Fedoraproject Fedora, published on 12 Jul 2021. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2021-32678 and fix it if it is affected.\n\nWhat it is: CVE-2021-32678 is a low-severity vulnerability in Fedoraproject Fedora, published on 12 Jul 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2021-32678 in the wild and no public exploit code.\n\nAffected product: Fedoraproject Fedora. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-32678/ (Markdown: https://insights.sbomify.com/CVE-2021-32678/index.md)","id":"CVE-2021-32678","markdown":"https://insights.sbomify.com/CVE-2021-32678/index.md","name":"CVE-2021-32678","record":{"aliases":["GHSA-48rx-3gmf-g74j"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["security_bypass","denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Nextcloud Server","requires_auth":"none","summary":"Attackers can bypass brute-force protection on OCS API endpoints, enabling authentication bypass or user spamming in Nextcloud Server.","user_interaction":"not_required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"fedora","vendor":"fedoraproject"},{"product":"nextcloud_server","vendor":"nextcloud"}],"cvss":{"score":3.7,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-307","name":"Improper Restriction of Excessive Authentication Attempts"},{"id":"CWE-799","name":"Improper Control of Interaction Frequency"}],"description":"Nextcloud Server is a Nextcloud package that handles data storage. In versions prior to 19.0.13, 20.0.11, and 21.0.3, ratelimits are not applied to OCS API responses. This affects any OCS API controller (`OCSController`) using the `@BruteForceProtection` annotation. Risk depends on the installed applications on the Nextcloud Server, but could range from bypassing authentication ratelimits or spamming other Nextcloud users. The vulnerability is patched in versions 19.0.13, 20.0.11, and 21.0.3. No workarounds aside from upgrading are known to exist.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Ratelimit not applied on OCS API responses","id":"CVE-2021-32678","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"fedoraproject:fedora","products":["fedoraproject:fedora","nextcloud:nextcloud_server"],"type":"security_feature_bypass","year":"2021"},"n_packages":0,"n_references":6,"next":{"headline":"Filenames not escaped by default in controllers using DownloadResponse","id":"CVE-2021-32679"},"packages":[],"prev":{"headline":"Cross-Site Request Forgery (CSRF) in FastAPI","id":"CVE-2021-32677"},"products":["security-advisories"],"published":"2021-07-12","related":[{"cvss_score":9.8,"headline":"PHP-CGI OS Command Injection","id":"CVE-2024-4577","kev_date_added":"2024-06-12","published":"2024-06-09"},{"cvss_score":9.8,"headline":"Grafana Authentication Bypass","id":"CVE-2021-39226","kev_date_added":"2022-08-25","published":"2021-10-05"},{"cvss_score":9.8,"headline":"VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow","id":"CVE-2019-5544","kev_date_added":"2021-11-03","published":"2019-12-06"},{"cvss_score":9.6,"headline":"Google Chromium V8 Type Confusion","id":"CVE-2024-4947","kev_date_added":"2024-05-20","published":"2024-05-15"},{"cvss_score":9.6,"headline":"Google Chromium Visuals Use-After-Free","id":"CVE-2024-4671","kev_date_added":"2024-05-13","published":"2024-05-09"},{"cvss_score":9.6,"headline":"Google Chromium Mojo Insufficient Data Validation","id":"CVE-2022-3075","kev_date_added":"2022-09-08","published":"2022-09-26"},{"cvss_score":9.6,"headline":"Google Chromium Indexed DB API Use-After-Free","id":"CVE-2021-30633","kev_date_added":"2021-11-03","published":"2021-10-08"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["nextcloud"]},"summary":"Attackers can bypass brute-force protection on OCS API endpoints, enabling authentication bypass or user spamming in Nextcloud Server.","url":"https://insights.sbomify.com/CVE-2021-32678/"}