# CVE-2021-32684: Missing Handler in @scandipwa/magento-scripts

> Missing error handlers in Magento deployment scripts cause commands to fail, resulting in a denial of service for users of the tool.

- **Severity:** Medium 6.2 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Jun 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-52qp-gwwh-qrg4

## What is CVE-2021-32684?

CVE-2021-32684 is a medium-severity denial of service vulnerability in scandipwa create-magento-app, published on 14 Jun 2021. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

magento-scripts contains scripts and configuration used by Create Magento App, a zero-configuration tool-chain which allows one to deploy Magento 2. In versions 1.5.1 and 1.5.2, after changing the function from synchronous to asynchronous there wasn't implemented handler in the start, stop, exec, and logs commands, effectively making them unusable. Version 1.5.3 contains patches for the problems.

Weakness: CWE-670 (Always-Incorrect Control Flow Implementation)

## Which versions are affected by CVE-2021-32684?

2 open source packages ship an affected version, including @scandipwa/magento-scripts. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@scandipwa/magento-scripts` | npm | From 1.5.1 | 1.5.3 |
| `@scandipwa/magento-scripts` | npm | From 1.5.1 | 1.5.3 |

Products: Scandipwa Magento-Scripts.

## How do I fix CVE-2021-32684?

Upgrade @scandipwa/magento-scripts to 1.5.3 or later.

## Is CVE-2021-32684 being exploited?

There is no known exploitation of CVE-2021-32684 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-32684 and fix it if it is affected.

What it is: CVE-2021-32684 is a medium-severity denial of service vulnerability in scandipwa create-magento-app, published on 14 Jun 2021. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-32684 in the wild and no public exploit code.

Affected packages and fixed versions:
- @scandipwa/magento-scripts (npm): affected from 1.5.1; fixed in 1.5.3
- @scandipwa/magento-scripts (npm): affected from 1.5.1; fixed in 1.5.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-32684/ (Markdown: https://insights.sbomify.com/CVE-2021-32684/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-32684
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-32684
- OSV: https://osv.dev/vulnerability/CVE-2021-32684

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-32684/
Summaries are generated and may contain mistakes; the official description above is the record.
