# CVE-2021-32690: Repository credentials passed to alternate domain

> Helm leaks repository credentials to alternate domains when installing charts, exposing sensitive authentication data to attackers.

- **Severity:** Medium 6.8 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Jun 2021
- **Updated:** 3 Aug 2024
- **Also known as:** AZL-6471, BIT-helm-2021-32690, GHSA-56hp-xqp3-w2jf, GHSA-7jr6-prv4-5wf5, GO-2022-0384

## What is CVE-2021-32690?

CVE-2021-32690 is a medium-severity vulnerability in helm, published on 16 Jun 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Helm is a tool for managing Charts (packages of pre-configured Kubernetes resources). In versions of helm prior to 3.6.1, a vulnerability exists where the username and password credentials associated with a Helm repository could be passed on to another domain referenced by that Helm repository. This issue has been resolved in 3.6.1. There is a workaround through which one may check for improperly passed credentials. One may use a username and password for a Helm repository and may audit the Helm repository in order to check for another domain being used that could have received the credentials. In the `index.yaml` file for that repository, one may look for another domain in the `urls` list for the chart versions. If there is another domain found and that chart version was pulled or installed, the credentials would be passed on.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2021-32690?

6 open source packages ship an affected version, including helm.sh/helm/v3 and helm. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `helm.sh/helm/v3` | Go | All versions | 3.6.1 |
| `helm.sh/helm/v3` | Go | All versions | 3.6.1 |
| `helm.sh/helm/v3` | Go | All versions | 3.6.1 |
| `helm.sh/helm/v3` | Go | All versions | 3.6.1 |
| `helm.sh/helm/v3` | Go | All versions | 3.6.1 |
| `helm` | Bitnami | All versions | 3.6.1 |

Products: Helm Helm.

## How do I fix CVE-2021-32690?

Upgrade helm.sh/helm/v3 to 3.6.1 or later.

## Is CVE-2021-32690 being exploited?

There is no known exploitation of CVE-2021-32690 in the wild and no public exploit code.

## Other vulnerabilities in helm

- [CVE-2019-18658](https://insights.sbomify.com/CVE-2019-18658/): Helm Unsafe Link Following (critical 9.8)
- [CVE-2019-1010275](https://insights.sbomify.com/CVE-2019-1010275/): Helm Improper Certificate Validation (critical 9.8)
- [CVE-2019-25210](https://insights.sbomify.com/CVE-2019-25210/): Information disclosure in n/a (critical 9.1)
- [CVE-2025-53547](https://insights.sbomify.com/CVE-2025-53547/): Helm Chart Dependency Updating With Malicious Chart.yaml Content And Symlink Can Lead To Code Execution (high 8.5)
- [CVE-2020-11013](https://insights.sbomify.com/CVE-2020-11013/): lookup Function Information Discolosure in Helm (high 8.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-32690 and fix it if it is affected.

What it is: CVE-2021-32690 is a medium-severity vulnerability in helm, published on 16 Jun 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-32690 in the wild and no public exploit code.

Affected packages and fixed versions:
- helm.sh/helm/v3 (Go): affected all versions; fixed in 3.6.1
- helm.sh/helm/v3 (Go): affected all versions; fixed in 3.6.1
- helm.sh/helm/v3 (Go): affected all versions; fixed in 3.6.1
- helm.sh/helm/v3 (Go): affected all versions; fixed in 3.6.1
- helm.sh/helm/v3 (Go): affected all versions; fixed in 3.6.1
- helm (Bitnami): affected all versions; fixed in 3.6.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-32690/ (Markdown: https://insights.sbomify.com/CVE-2021-32690/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-32690
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-32690
- OSV: https://osv.dev/vulnerability/CVE-2021-32690

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-32690/
Summaries are generated and may contain mistakes; the official description above is the record.
