# CVE-2021-32691: Auto-merging Person Records Compromised

> Attackers can access any user account using only basic profile information, compromising app functionality and authenticated links.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 16 Jun 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-r578-pj6f-r4ff

## What is CVE-2021-32691?

CVE-2021-32691 is a high-severity authentication bypass vulnerability in ApollosProject apollos-apps, published on 16 Jun 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Apollos Apps is an open source platform for launching church-related apps. In Apollos Apps versions prior to 2.20.0, new user registrations are able to access anyone's account by only knowing their basic profile information (name, birthday, gender, etc). This includes all app functionality within the app, as well as any authenticated links to Rock-based webpages (such as giving and events). There is a patch in version 2.20.0. As a workaround, one can patch one's server by overriding the `create` data source method on the `People` class.

Weakness: CWE-287 (Improper Authentication), CWE-303 (Incorrect Implementation of Authentication Algorithm)

## Which versions are affected by CVE-2021-32691?

2 open source packages ship an affected version, including @apollosproject/data-connector-rock. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@apollosproject/data-connector-rock` | npm | All versions | 2.20.0 |
| `@apollosproject/data-connector-rock` | npm | All versions | 2.20.0 |

Products: Apollosapp Data-Connector-Rock.

## How do I fix CVE-2021-32691?

Upgrade @apollosproject/data-connector-rock to 2.20.0 or later.

## Is CVE-2021-32691 being exploited?

There is no known exploitation of CVE-2021-32691 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-32691 and fix it if it is affected.

What it is: CVE-2021-32691 is a high-severity authentication bypass vulnerability in ApollosProject apollos-apps, published on 16 Jun 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2021-32691 in the wild and no public exploit code.

Affected packages and fixed versions:
- @apollosproject/data-connector-rock (npm): affected all versions; fixed in 2.20.0
- @apollosproject/data-connector-rock (npm): affected all versions; fixed in 2.20.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-32691/ (Markdown: https://insights.sbomify.com/CVE-2021-32691/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-32691
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-32691
- OSV: https://osv.dev/vulnerability/CVE-2021-32691

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-32691/
Summaries are generated and may contain mistakes; the official description above is the record.
