# CVE-2021-32693: Authentication granted with multiple firewalls

> Attackers can bypass authentication boundaries in Symfony apps with multiple firewalls, gaining unauthorized access to protected areas.

- **Severity:** Medium 6.8 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Jun 2021
- **Updated:** 3 Aug 2024
- **Also known as:** BIT-symfony-2021-32693, GHSA-rfcf-m67m-jcrq

## What is CVE-2021-32693?

CVE-2021-32693 is a medium-severity authentication bypass vulnerability in Sensiolabs Symfony, published on 17 Jun 2021. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Symfony is a PHP framework for web and console applications and a set of reusable PHP components. A vulnerability related to firewall authentication is in Symfony starting with version 5.3.0 and prior to 5.3.2. When an application defines multiple firewalls, the token authenticated by one of the firewalls was available for all other firewalls. This could be abused when the application defines different providers for each part of the application, in such a situation, a user authenticated on a part of the application could be considered authenticated on the rest of the application. Starting in version 5.3.2, a patch ensures that the authenticated token is only available for the firewall that generates it.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2021-32693?

5 open source packages ship an affected version, including symfony/security-http, symfony and symfony/symfony. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `symfony/security-http` | Packagist | From 5.3.0 | 5.3.2 |
| `symfony/security-http` | Packagist | From 5.3.0 | 5.3.2 |
| `symfony` | Bitnami | From 5.3.0 | 5.3.2 |
| `symfony/symfony` | Packagist | From 5.3.0 | 5.3.2 |
| `symfony/symfony` | Packagist | From 5.3.0 | 5.3.2 |

Products: Sensiolabs Symfony.

## How do I fix CVE-2021-32693?

Upgrade symfony/security-http to 5.3.2 or later.

## Is CVE-2021-32693 being exploited?

There is no known exploitation of CVE-2021-32693 in the wild and no public exploit code.

## Other vulnerabilities in Sensiolabs Symfony

- [CVE-2019-11325](https://insights.sbomify.com/CVE-2019-11325/): Improper Input Validation in Symfony (critical 9.8)
- [CVE-2017-11365](https://insights.sbomify.com/CVE-2017-11365/): Symfony Incorrect Access Control (critical 9.8)
- [CVE-2019-10913](https://insights.sbomify.com/CVE-2019-10913/): Invalid HTTP method overrides allow possible XSS or other attacks in Symfony (critical 9.8)
- [CVE-2018-11407](https://insights.sbomify.com/CVE-2018-11407/): Symfony Authentication Bypass (critical 9.8)
- [CVE-2016-2403](https://insights.sbomify.com/CVE-2016-2403/): Symfony Authentication Bypass (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-32693 and fix it if it is affected.

What it is: CVE-2021-32693 is a medium-severity authentication bypass vulnerability in Sensiolabs Symfony, published on 17 Jun 2021. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-32693 in the wild and no public exploit code.

Affected packages and fixed versions:
- symfony/security-http (Packagist): affected from 5.3.0; fixed in 5.3.2
- symfony/security-http (Packagist): affected from 5.3.0; fixed in 5.3.2
- symfony (Bitnami): affected from 5.3.0; fixed in 5.3.2
- symfony/symfony (Packagist): affected from 5.3.0; fixed in 5.3.2
- symfony/symfony (Packagist): affected from 5.3.0; fixed in 5.3.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-32693/ (Markdown: https://insights.sbomify.com/CVE-2021-32693/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-32693
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-32693
- OSV: https://osv.dev/vulnerability/CVE-2021-32693

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-32693/
Summaries are generated and may contain mistakes; the official description above is the record.
