# CVE-2021-32696: Passing in a non-string 'html' argument can lead to unsanitized output

> Attackers can trigger XSS in applications using striptags by passing array-like objects, bypassing sanitization via type confusion.

- **Severity:** Low 3.7 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Jun 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-qxg5-2qff-p49r

## What is CVE-2021-32696?

CVE-2021-32696 is a low-severity cross-site scripting vulnerability in ericnorris striptags, published on 18 Jun 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The npm package "striptags" is an implementation of PHP's strip_tags in Typescript. In striptags before version 3.2.0, a type-confusion vulnerability can cause `striptags` to concatenate unsanitized strings when an array-like object is passed in as the `html` parameter. This can be abused by an attacker who can control the shape of their input, e.g. if query parameters are passed directly into the function. This can lead to a XSS.

Weakness: CWE-843 (Access of Resource Using Incompatible Type), CWE-79 (Improper Neutralization of Input During Web Page Generation), CWE-241 (Improper Handling of Unexpected Data Type)

## Which versions are affected by CVE-2021-32696?

2 open source packages ship an affected version, including striptags. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `striptags` | npm | All versions | 3.2.0 |
| `striptags` | npm | All versions | 3.2.0 |

Products: Striptags Project Striptags.

## How do I fix CVE-2021-32696?

Upgrade striptags to 3.2.0 or later.

## Is CVE-2021-32696 being exploited?

There is no known exploitation of CVE-2021-32696 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-32696 and fix it if it is affected.

What it is: CVE-2021-32696 is a low-severity cross-site scripting vulnerability in ericnorris striptags, published on 18 Jun 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-32696 in the wild and no public exploit code.

Affected packages and fixed versions:
- striptags (npm): affected all versions; fixed in 3.2.0
- striptags (npm): affected all versions; fixed in 3.2.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-32696/ (Markdown: https://insights.sbomify.com/CVE-2021-32696/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-32696
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-32696
- OSV: https://osv.dev/vulnerability/CVE-2021-32696

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-32696/
Summaries are generated and may contain mistakes; the official description above is the record.
