# CVE-2021-32699: Asymmetric Resource Consumption (Amplification) in Docker containers created by Wings

> A malicious user can exhaust system resources in Pterodactyl Wings, causing denial of service on the host server.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:C/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Jun 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-jj6m-r8jc-2gp7, GO-2022-0919

## What is CVE-2021-32699?

CVE-2021-32699 is a medium-severity denial of service vulnerability in pterodactyl wings, published on 22 Jun 2021. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Wings is the control plane software for the open source Pterodactyl game management system. All versions of Pterodactyl Wings prior to `1.4.4` are vulnerable to system resource exhaustion due to improper container process limits being defined. A malicious user can consume more resources than intended and cause downstream impacts to other clients on the same hardware, eventually causing the physical server to stop responding. Users should upgrade to `1.4.4` to mitigate the issue. There is no non-code based workaround for impacted versions of the software. Users running customized versions of this software can manually set a PID limit for containers created.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling), CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2021-32699?

3 open source packages ship an affected version, including github.com/pterodactyl/wings. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/pterodactyl/wings` | Go | All versions | 1.4.4 |
| `github.com/pterodactyl/wings` | Go | All versions | 1.4.4 |
| `github.com/pterodactyl/wings` | Go | All versions | 1.4.4 |

Products: Pterodactyl Wings.

## How do I fix CVE-2021-32699?

Upgrade github.com/pterodactyl/wings to 1.4.4 or later.

## Is CVE-2021-32699 being exploited?

There is no known exploitation of CVE-2021-32699 in the wild and no public exploit code.

## Other vulnerabilities in pterodactyl wings

- [CVE-2024-27102](https://insights.sbomify.com/CVE-2024-27102/): Improper isolation of server file access in github.com/pterodactyl/wings (critical 10.0)
- [CVE-2023-25168](https://insights.sbomify.com/CVE-2023-25168/): Symbolic Link (Symlink) Following allowing the deletion of files and directories on the host system in wings (critical 9.6)
- [CVE-2023-32080](https://insights.sbomify.com/CVE-2023-32080/): Wings vulnerable to escape to host from installation container (critical 9.1)
- [CVE-2024-34066](https://insights.sbomify.com/CVE-2024-34066/): Arbitrary File Write/Read in Pterodactyl wings (high 8.5)
- [CVE-2023-25152](https://insights.sbomify.com/CVE-2023-25152/): Symbolic Link (Symlink) Following in github.com/pterodactyl/wings (high 8.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-32699 and fix it if it is affected.

What it is: CVE-2021-32699 is a medium-severity denial of service vulnerability in pterodactyl wings, published on 22 Jun 2021. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-32699 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/pterodactyl/wings (Go): affected all versions; fixed in 1.4.4
- github.com/pterodactyl/wings (Go): affected all versions; fixed in 1.4.4
- github.com/pterodactyl/wings (Go): affected all versions; fixed in 1.4.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-32699/ (Markdown: https://insights.sbomify.com/CVE-2021-32699/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-32699
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-32699
- OSV: https://osv.dev/vulnerability/CVE-2021-32699

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-32699/
Summaries are generated and may contain mistakes; the official description above is the record.
