{"answers":{"affected":"2 open source packages ship an affected version, including @auth0/nextjs-auth0. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-32702 in the wild and no public exploit code.","fix":"Upgrade @auth0/nextjs-auth0 to 1.4.2 or later.","what":"CVE-2021-32702 is a high-severity cross-site scripting vulnerability in nextjs-auth0, published on 25 Jun 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2021-32702 and fix it if it is affected.\n\nWhat it is: CVE-2021-32702 is a high-severity cross-site scripting vulnerability in nextjs-auth0, published on 25 Jun 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2021-32702 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- @auth0/nextjs-auth0 (npm): affected all versions; fixed in 1.4.2\n- @auth0/nextjs-auth0 (npm): affected all versions; fixed in 1.4.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-32702/ (Markdown: https://insights.sbomify.com/CVE-2021-32702/index.md)","id":"CVE-2021-32702","markdown":"https://insights.sbomify.com/CVE-2021-32702/index.md","name":"CVE-2021-32702","record":{"aliases":["GHSA-954c-jjx6-cxv7"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Next.js Auth0 SDK","requires_auth":"none","summary":"Attackers can execute arbitrary JavaScript via reflected XSS in the callback error parameter, affecting Next.js applications using the Auth0 SDK.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"nextjs-auth0","vendor":"auth0"}],"cvss":{"score":8,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"The Auth0 Next.js SDK is a library for implementing user authentication in Next.js applications. Versions before and including `1.4.1` are vulnerable to reflected XSS. An attacker can execute arbitrary code by providing an XSS payload in the `error` query parameter which is then processed by the callback handler as an error message. You are affected by this vulnerability if you are using `@auth0/nextjs-auth0` version `1.4.1` or lower **unless** you are using custom error handling that does not return the error message in an HTML response. Upgrade to version `1.4.1` to resolve. The fix adds basic HTML escaping to the error message and it should not impact your users.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Reflected XSS from the callback handler's error query parameter","id":"CVE-2021-32702","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2021"},"n_packages":2,"n_references":3,"next":{"headline":"Lack of ratelimit on shareinfo endpoint","id":"CVE-2021-32703"},"packages":[{"ecosystem":"npm","fixed":["1.4.2"],"introduced":["0"],"last_affected":[],"package":"@auth0/nextjs-auth0","purl":null,"source":"GHSA-954c-jjx6-cxv7"},{"ecosystem":"npm","fixed":["1.4.2"],"introduced":["0"],"last_affected":[],"package":"@auth0/nextjs-auth0","purl":"pkg:npm/%40auth0/nextjs-auth0","source":"GHSA-954c-jjx6-cxv7"}],"prev":{"headline":"Possible bypass of token claim validation when OAuth2 Introspection caching is enabled","id":"CVE-2021-32701"},"products":["nextjs-auth0"],"published":"2021-06-25","related":[{"cvss_score":6.4,"headline":"Open redirect in nextjs-auth0","id":"CVE-2021-43812","kev_date_added":null,"published":"2021-12-16"},{"cvss_score":5.7,"headline":"Auth0 Next.js SDK has Improper Validation of Query Parameters","id":"CVE-2025-67716","kev_date_added":null,"published":"2025-12-11"},{"cvss_score":5.4,"headline":"Auth0 Next.js SDK has Improper Proxy Cache Lookup","id":"CVE-2026-40155","kev_date_added":null,"published":"2026-04-17"},{"cvss_score":5.4,"headline":"Auth0 Next.js SDK has Improper Request Caching Lookup","id":"CVE-2025-67490","kev_date_added":null,"published":"2025-12-10"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["auth0"]},"summary":"Attackers can execute arbitrary JavaScript via reflected XSS in the callback error parameter, affecting Next.js applications using the Auth0 SDK.","url":"https://insights.sbomify.com/CVE-2021-32702/"}