# CVE-2021-3271: Stored cross-site scripting in PressBooks

> Attackers can inject malicious scripts via the Book Info Long Description field, leading to code execution or account takeover when users view the book.

- **Severity:** Medium 4.8 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 22 Jan 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-9652-78hp-w58c

## What is CVE-2021-3271?

CVE-2021-3271 is a medium-severity cross-site scripting vulnerability in n/a, published on 22 Jan 2021. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

PressBooks 5.17.3 contains a cross-site scripting (XSS). Stored XSS can be submitted via the Book Info's Long Description Body, and all actions to open or preview the books page will result in the triggering the stored XSS.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2021-3271?

2 open source packages ship an affected version, including pressbooks/pressbooks. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pressbooks/pressbooks` | Packagist | All versions | 5.18.0 |
| `pressbooks/pressbooks` | Packagist | All versions | 5.18.0 |

Products: Pressbooks Pressbooks.

## How do I fix CVE-2021-3271?

Upgrade pressbooks/pressbooks to 5.18.0 or later.

## Is CVE-2021-3271 being exploited?

There is no known exploitation of CVE-2021-3271 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-3271 and fix it if it is affected.

What it is: CVE-2021-3271 is a medium-severity cross-site scripting vulnerability in n/a, published on 22 Jan 2021. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2021-3271 in the wild and no public exploit code.

Affected packages and fixed versions:
- pressbooks/pressbooks (Packagist): affected all versions; fixed in 5.18.0
- pressbooks/pressbooks (Packagist): affected all versions; fixed in 5.18.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-3271/ (Markdown: https://insights.sbomify.com/CVE-2021-3271/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-3271
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-3271
- OSV: https://osv.dev/vulnerability/CVE-2021-3271

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-3271/
Summaries are generated and may contain mistakes; the official description above is the record.
