CVE-2021-32710 Potential Session Hijacking in Shopware
- Exploited in the wild
- Not known
- Fix
- Available
What is CVE-2021-32710?
CVE-2021-32710 is a medium-severity vulnerability in Shopware Shopware, published on 24 Jun 2021.
Official description
Shopware is an open source eCommerce platform. Potential session hijacking of store customers in versions below 6.3.5.2. We recommend to update to the current version 6.3.5.2. You can get the update to 6.3.5.2 regularly via the Auto-Updater or directly via the download overview. For older versions of 6.1 and 6.2, corresponding security measures are also available via a plugin. For the full range of functions, we recommend updating to the latest Shopware version.
Weakness: CWE-384
Which versions are affected by CVE-2021-32710?
2 open source packages ship an affected version, including shopware/platform. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
shopware/platform Packagist | All versions | 6.3.5.2 |
shopware/platform Packagist | All versions | 6.3.5.2 |
Products include Shopware Shopware.
How do I fix CVE-2021-32710?
Upgrade shopware/platform to 6.3.5.2 or later.
Is CVE-2021-32710 being exploited?
There is no known exploitation of CVE-2021-32710 in the wild and no public exploit code.
Other vulnerabilities in Shopware Shopware
- CVE-2023-22731 Improper Control of Generation of Code in Twig rendered views in shopware
- CVE-2016-3109 Shopware RCE Vulnerability
- CVE-2024-22406 Blind SQL-injection in DAL aggregations in Shopware
- CVE-2021-32711 Leak of information via Store-API
- CVE-2026-31887 Shopware unauthenticated data extraction possible through store-api.order endpoint
Sources
Also known as GHSA-h9q8-5gv2-v6mg.