CVE-2021-32711 Leak of information via Store-API
Attackers can leak sensitive information via the Store-API in Shopware, requiring an upgrade to the latest version to resolve.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2021-32711?
CVE-2021-32711 is a critical vulnerability in Shopware Shopware, published on 24 Jun 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Shopware is an open source eCommerce platform. Versions prior to 6.3.5.1 may leak of information via Store-API. The vulnerability could only be fixed by changing the API system, which involves a non-backward-compatible change. Only consumers of the Store-API should be affected by this change. We recommend to update to the current version 6.3.5.1. You can get the update to 6.3.5.1 regularly via the Auto-Updater or directly via the download overview. https://www.shopware.com/en/download/#shopware-6 The vulnerability could only be fixed by changing the API system, which involves a non-backward-compatible change. Only consumers of the Store-API should be affected by this change. Please check your plugins if you have it in use. Detailed technical information can be found in the upgrade information. https://github.com/shopware/platform/blob/v6.3.5.1/UPGRADE-6.3.md#6351 ### Workarounds For older versions of 6.1 and 6.2, corresponding security measures are also available via a plugin. For the full range of functions, we recommend updating to the latest Shopware version. https://store.shopware.com/en/detail/index/sArticle/518463/number/Swag136939272659 ### For more information https://docs.shopware.com/en/shopware-6-en/security-updates/security-update-02-2021
Weakness: CWE-200
Which versions are affected by CVE-2021-32711?
4 open source packages ship an affected version, including shopware/platform. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
shopware/platform Packagist | All versions | 6.3.5.1 |
shopware/platform Packagist | All versions | 6.3.5.1 |
shopware/platform Packagist | All versions | 6.3.5.1 |
shopware/platform Packagist | All versions | 6.3.5.1 |
Products include Shopware Shopware.
How do I fix CVE-2021-32711?
Upgrade shopware/platform to 6.3.5.1 or later.
Is CVE-2021-32711 being exploited?
There is no known exploitation of CVE-2021-32711 in the wild and no public exploit code.
Other vulnerabilities in Shopware Shopware
- CVE-2023-22731 Improper Control of Generation of Code in Twig rendered views in shopware
- CVE-2016-3109 Shopware RCE Vulnerability
- CVE-2024-22406 Blind SQL-injection in DAL aggregations in Shopware
- CVE-2026-31887 Shopware unauthenticated data extraction possible through store-api.order endpoint
- CVE-2026-31889 Shopware has a potential take over of app credentials
Sources
Also known as GHSA-2p89-5f22-8qvf, GHSA-f2vv-h5x4-57gr.