# CVE-2021-32711: Leak of information via Store-API

> Attackers can leak sensitive information via the Store-API in Shopware, requiring an upgrade to the latest version to resolve.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Jun 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-2p89-5f22-8qvf, GHSA-f2vv-h5x4-57gr

## What is CVE-2021-32711?

CVE-2021-32711 is a critical vulnerability in Shopware Shopware, published on 24 Jun 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Shopware is an open source eCommerce platform. Versions prior to 6.3.5.1 may leak of information via Store-API. The vulnerability could only be fixed by changing the API system, which involves a non-backward-compatible change. Only consumers of the Store-API should be affected by this change. We recommend to update to the current version 6.3.5.1. You can get the update to 6.3.5.1 regularly via the Auto-Updater or directly via the download overview. https://www.shopware.com/en/download/#shopware-6 The vulnerability could only be fixed by changing the API system, which involves a non-backward-compatible change. Only consumers of the Store-API should be affected by this change. Please check your plugins if you have it in use. Detailed technical information can be found in the upgrade information. https://github.com/shopware/platform/blob/v6.3.5.1/UPGRADE-6.3.md#6351 ### Workarounds For older versions of 6.1 and 6.2, corresponding security measures are also available via a plugin. For the full range of functions, we recommend updating to the latest Shopware version. https://store.shopware.com/en/detail/index/sArticle/518463/number/Swag136939272659 ### For more information https://docs.shopware.com/en/shopware-6-en/security-updates/security-update-02-2021

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2021-32711?

4 open source packages ship an affected version, including shopware/platform. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `shopware/platform` | Packagist | All versions | 6.3.5.1 |
| `shopware/platform` | Packagist | All versions | 6.3.5.1 |
| `shopware/platform` | Packagist | All versions | 6.3.5.1 |
| `shopware/platform` | Packagist | All versions | 6.3.5.1 |

Products: Shopware Shopware.

## How do I fix CVE-2021-32711?

Upgrade shopware/platform to 6.3.5.1 or later.

## Is CVE-2021-32711 being exploited?

There is no known exploitation of CVE-2021-32711 in the wild and no public exploit code.

## Other vulnerabilities in Shopware Shopware

- [CVE-2023-22731](https://insights.sbomify.com/CVE-2023-22731/): Improper Control of Generation of Code in Twig rendered views in shopware (critical 10.0)
- [CVE-2016-3109](https://insights.sbomify.com/CVE-2016-3109/): Shopware RCE Vulnerability (critical 9.8)
- [CVE-2024-22406](https://insights.sbomify.com/CVE-2024-22406/): Blind SQL-injection in DAL aggregations in Shopware (critical 9.3)
- [CVE-2026-31887](https://insights.sbomify.com/CVE-2026-31887/): Shopware unauthenticated data extraction possible through store-api.order endpoint (high 8.9)
- [CVE-2026-31889](https://insights.sbomify.com/CVE-2026-31889/): Shopware has a potential take over of app credentials (high 8.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-32711 and fix it if it is affected.

What it is: CVE-2021-32711 is a critical vulnerability in Shopware Shopware, published on 24 Jun 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-32711 in the wild and no public exploit code.

Affected packages and fixed versions:
- shopware/platform (Packagist): affected all versions; fixed in 6.3.5.1
- shopware/platform (Packagist): affected all versions; fixed in 6.3.5.1
- shopware/platform (Packagist): affected all versions; fixed in 6.3.5.1
- shopware/platform (Packagist): affected all versions; fixed in 6.3.5.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-32711/ (Markdown: https://insights.sbomify.com/CVE-2021-32711/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-32711
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-32711
- OSV: https://osv.dev/vulnerability/CVE-2021-32711

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-32711/
Summaries are generated and may contain mistakes; the official description above is the record.
