CVE-2021-32714 Integer Overflow in Chunked Transfer-Encoding

Medium 5.9 Published Updated
Exploited in the wild
Not known
Fix
Available

What is CVE-2021-32714?

CVE-2021-32714 is a medium-severity vulnerability in hyperium hyper, published on 7 Jul 2021.

Official description

hyper is an HTTP library for Rust. In versions prior to 0.14.10, hyper's HTTP server and client code had a flaw that could trigger an integer overflow when decoding chunk sizes that are too big. This allows possible data loss, or if combined with an upstream HTTP proxy that allows chunk sizes larger than hyper does, can result in "request smuggling" or "desync attacks." The vulnerability is patched in version 0.14.10. Two possible workarounds exist. One may reject requests manually that contain a `Transfer-Encoding` header or ensure any upstream proxy rejects `Transfer-Encoding` chunk sizes greater than what fits in 64-bit unsigned integers.

Weakness: CWE-190

Which versions are affected by CVE-2021-32714?

3 open source packages ship an affected version, including hyper. It affects 1 product.

PackageAffectedFixed in
hyper crates.ioAll versions0.14.10
hyper crates.ioAll versions0.14.10
hyper crates.ioFrom 0.0.0-00.14.10

Products include Hyper Hyper.

How do I fix CVE-2021-32714?

Upgrade hyper to 0.14.10 or later.

Is CVE-2021-32714 being exploited?

There is no known exploitation of CVE-2021-32714 in the wild and no public exploit code.

Sources

Also known as DEBIAN-CVE-2021-32714, GHSA-5h46-h7hh-c6x9, RUSTSEC-2021-0079, UBUNTU-CVE-2021-32714.

Is CVE-2021-32714 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free