# CVE-2021-32714: Integer Overflow in Chunked Transfer-Encoding


- **Severity:** Medium 5.9 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 7 Jul 2021
- **Updated:** 3 Aug 2024
- **Also known as:** DEBIAN-CVE-2021-32714, GHSA-5h46-h7hh-c6x9, RUSTSEC-2021-0079, UBUNTU-CVE-2021-32714

## What is CVE-2021-32714?

CVE-2021-32714 is a medium-severity vulnerability in hyperium hyper, published on 7 Jul 2021. 

### Official description

hyper is an HTTP library for Rust. In versions prior to 0.14.10, hyper's HTTP server and client code had a flaw that could trigger an integer overflow when decoding chunk sizes that are too big. This allows possible data loss, or if combined with an upstream HTTP proxy that allows chunk sizes larger than hyper does, can result in "request smuggling" or "desync attacks." The vulnerability is patched in version 0.14.10. Two possible workarounds exist. One may reject requests manually that contain a `Transfer-Encoding` header or ensure any upstream proxy rejects `Transfer-Encoding` chunk sizes greater than what fits in 64-bit unsigned integers.

Weakness: CWE-190 (Integer Overflow or Wraparound)

## Which versions are affected by CVE-2021-32714?

3 open source packages ship an affected version, including hyper. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `hyper` | crates.io | All versions | 0.14.10 |
| `hyper` | crates.io | All versions | 0.14.10 |
| `hyper` | crates.io | From 0.0.0-0 | 0.14.10 |

Products: Hyper Hyper.

## How do I fix CVE-2021-32714?

Upgrade hyper to 0.14.10 or later.

## Is CVE-2021-32714 being exploited?

There is no known exploitation of CVE-2021-32714 in the wild and no public exploit code.

## Other vulnerabilities in hyperium hyper

- [CVE-2020-35863](https://insights.sbomify.com/CVE-2020-35863/): HTTP Request Smuggling in hyper (critical 9.8)
- [CVE-2022-31394](https://insights.sbomify.com/CVE-2022-31394/): Denial of service in n/a (high 7.5)
- [CVE-2017-18587](https://insights.sbomify.com/CVE-2017-18587/): Headers containing newline characters can split messages in hyper (medium 5.3)
- [CVE-2021-21299](https://insights.sbomify.com/CVE-2021-21299/): Multiple Transfer-Encoding headers misinterprets request payload (medium 4.8)
- [CVE-2016-10932](https://insights.sbomify.com/CVE-2016-10932/): HTTPS MitM vulnerability due to lack of hostname verification (medium 4.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-32714 and fix it if it is affected.

What it is: CVE-2021-32714 is a medium-severity vulnerability in hyperium hyper, published on 7 Jul 2021. 
Exploitation: There is no known exploitation of CVE-2021-32714 in the wild and no public exploit code.

Affected packages and fixed versions:
- hyper (crates.io): affected all versions; fixed in 0.14.10
- hyper (crates.io): affected all versions; fixed in 0.14.10
- hyper (crates.io): affected from 0.0.0-0; fixed in 0.14.10

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-32714/ (Markdown: https://insights.sbomify.com/CVE-2021-32714/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-32714
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-32714
- OSV: https://osv.dev/vulnerability/CVE-2021-32714

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-32714/
Summaries are generated and may contain mistakes; the official description above is the record.
