{"answers":{"affected":"3 open source packages ship an affected version, including hyper. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-32715 in the wild and no public exploit code.","fix":"Upgrade hyper to 0.14.10 or later.","what":"CVE-2021-32715 is a low-severity vulnerability in hyperium hyper, published on 7 Jul 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2021-32715 and fix it if it is affected.\n\nWhat it is: CVE-2021-32715 is a low-severity vulnerability in hyperium hyper, published on 7 Jul 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2021-32715 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- hyper (crates.io): affected all versions; fixed in 0.14.10\n- hyper (crates.io): affected all versions; fixed in 0.14.10\n- hyper (crates.io): affected from 0.0.0-0; fixed in 0.14.10\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-32715/ (Markdown: https://insights.sbomify.com/CVE-2021-32715/index.md)","id":"CVE-2021-32715","markdown":"https://insights.sbomify.com/CVE-2021-32715/index.md","name":"CVE-2021-32715","record":{"aliases":["DEBIAN-CVE-2021-32715","GHSA-f3pg-qwvg-p99c","RUSTSEC-2021-0078","UBUNTU-CVE-2021-32715"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_modify","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Rust HTTP library","requires_auth":"none","summary":"Attackers can perform request smuggling or desync attacks by exploiting lenient Content-Length parsing in the hyper HTTP library.","user_interaction":"required","vuln_class":"other"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"hyper","vendor":"hyper"}],"cvss":{"score":3.1,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:L/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-444","name":"Inconsistent Interpretation of HTTP Requests"}],"description":"hyper is an HTTP library for rust. hyper's HTTP/1 server code had a flaw that incorrectly parses and accepts requests with a `Content-Length` header with a prefixed plus sign, when it should have been rejected as illegal. This combined with an upstream HTTP proxy that doesn't parse such `Content-Length` headers, but forwards them, can result in \"request smuggling\" or \"desync attacks\". The flaw exists in all prior versions of hyper prior to 0.14.10, if built with `rustc` v1.5.0 or newer. The vulnerability is patched in hyper version 0.14.10. Two workarounds exist: One may reject requests manually that contain a plus sign prefix in the `Content-Length` header or ensure any upstream proxy handles `Content-Length` headers with a plus sign prefix.","ecosystems":["crates.io"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Lenient Parsing of Content-Length Header When Prefixed with Plus Sign","id":"CVE-2021-32715","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"crates.io","product":null,"products":[],"type":"other","year":"2021"},"n_packages":3,"n_references":2,"next":{"headline":"Internal hidden fields are visible on to many associations in admin api","id":"CVE-2021-32716"},"packages":[{"ecosystem":"crates.io","fixed":["0.14.10"],"introduced":["0"],"last_affected":[],"package":"hyper","purl":null,"source":"GHSA-f3pg-qwvg-p99c"},{"ecosystem":"crates.io","fixed":["0.14.10"],"introduced":["0"],"last_affected":[],"package":"hyper","purl":"pkg:cargo/hyper","source":"GHSA-f3pg-qwvg-p99c"},{"ecosystem":"crates.io","fixed":["0.14.10"],"introduced":["0.0.0-0"],"last_affected":[],"package":"hyper","purl":"pkg:cargo/hyper","source":"RUSTSEC-2021-0078"}],"prev":{"headline":"Integer Overflow in Chunked Transfer-Encoding","id":"CVE-2021-32714"},"products":["hyper"],"published":"2021-07-07","related":[{"cvss_score":9.8,"headline":"HTTP Request Smuggling in hyper","id":"CVE-2020-35863","kev_date_added":null,"published":"2020-12-31"},{"cvss_score":7.5,"headline":"Denial of service in n/a","id":"CVE-2022-31394","kev_date_added":null,"published":"2023-02-21"},{"cvss_score":5.9,"headline":"Integer Overflow in Chunked Transfer-Encoding","id":"CVE-2021-32714","kev_date_added":null,"published":"2021-07-07"},{"cvss_score":5.3,"headline":"Headers containing newline characters can split messages in hyper","id":"CVE-2017-18587","kev_date_added":null,"published":"2019-08-26"},{"cvss_score":4.8,"headline":"Multiple Transfer-Encoding headers misinterprets request payload","id":"CVE-2021-21299","kev_date_added":null,"published":"2021-02-11"},{"cvss_score":4.8,"headline":"HTTPS MitM vulnerability due to lack of hostname verification","id":"CVE-2016-10932","kev_date_added":null,"published":"2019-08-26"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"open","licence":"CC0 1.0","name":"RustSec","prefix":"RUSTSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["hyperium"]},"summary":"Attackers can perform request smuggling or desync attacks by exploiting lenient Content-Length parsing in the hyper HTTP library.","url":"https://insights.sbomify.com/CVE-2021-32715/"}