# CVE-2021-32715: Lenient Parsing of Content-Length Header When Prefixed with Plus Sign

> Attackers can perform request smuggling or desync attacks by exploiting lenient Content-Length parsing in the hyper HTTP library.

- **Severity:** Low 3.1 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 7 Jul 2021
- **Updated:** 3 Aug 2024
- **Also known as:** DEBIAN-CVE-2021-32715, GHSA-f3pg-qwvg-p99c, RUSTSEC-2021-0078, UBUNTU-CVE-2021-32715

## What is CVE-2021-32715?

CVE-2021-32715 is a low-severity vulnerability in hyperium hyper, published on 7 Jul 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

hyper is an HTTP library for rust. hyper's HTTP/1 server code had a flaw that incorrectly parses and accepts requests with a `Content-Length` header with a prefixed plus sign, when it should have been rejected as illegal. This combined with an upstream HTTP proxy that doesn't parse such `Content-Length` headers, but forwards them, can result in "request smuggling" or "desync attacks". The flaw exists in all prior versions of hyper prior to 0.14.10, if built with `rustc` v1.5.0 or newer. The vulnerability is patched in hyper version 0.14.10. Two workarounds exist: One may reject requests manually that contain a plus sign prefix in the `Content-Length` header or ensure any upstream proxy handles `Content-Length` headers with a plus sign prefix.

Weakness: CWE-444 (Inconsistent Interpretation of HTTP Requests)

## Which versions are affected by CVE-2021-32715?

3 open source packages ship an affected version, including hyper. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `hyper` | crates.io | All versions | 0.14.10 |
| `hyper` | crates.io | All versions | 0.14.10 |
| `hyper` | crates.io | From 0.0.0-0 | 0.14.10 |

Products: Hyper Hyper.

## How do I fix CVE-2021-32715?

Upgrade hyper to 0.14.10 or later.

## Is CVE-2021-32715 being exploited?

There is no known exploitation of CVE-2021-32715 in the wild and no public exploit code.

## Other vulnerabilities in hyperium hyper

- [CVE-2020-35863](https://insights.sbomify.com/CVE-2020-35863/): HTTP Request Smuggling in hyper (critical 9.8)
- [CVE-2022-31394](https://insights.sbomify.com/CVE-2022-31394/): Denial of service in n/a (high 7.5)
- [CVE-2021-32714](https://insights.sbomify.com/CVE-2021-32714/): Integer Overflow in Chunked Transfer-Encoding (medium 5.9)
- [CVE-2017-18587](https://insights.sbomify.com/CVE-2017-18587/): Headers containing newline characters can split messages in hyper (medium 5.3)
- [CVE-2021-21299](https://insights.sbomify.com/CVE-2021-21299/): Multiple Transfer-Encoding headers misinterprets request payload (medium 4.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-32715 and fix it if it is affected.

What it is: CVE-2021-32715 is a low-severity vulnerability in hyperium hyper, published on 7 Jul 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2021-32715 in the wild and no public exploit code.

Affected packages and fixed versions:
- hyper (crates.io): affected all versions; fixed in 0.14.10
- hyper (crates.io): affected all versions; fixed in 0.14.10
- hyper (crates.io): affected from 0.0.0-0; fixed in 0.14.10

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-32715/ (Markdown: https://insights.sbomify.com/CVE-2021-32715/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-32715
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-32715
- OSV: https://osv.dev/vulnerability/CVE-2021-32715

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-32715/
Summaries are generated and may contain mistakes; the official description above is the record.
