# CVE-2021-32717: Private files publicly accessible with Cloud Storage providers

> Attackers can access private files if the hashed URL is known when using Cloud Storage providers with incorrect visibility settings.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Jun 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-6gr8-c3m5-mvrg, GHSA-vrf2-xghr-j52v

## What is CVE-2021-32717?

CVE-2021-32717 is a high-severity vulnerability in Shopware Shopware, published on 24 Jun 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Shopware is an open source eCommerce platform. In versions prior to 6.4.1.1 private files publicly accessible with Cloud Storage providers when the hashed URL is known. Users are recommend to first change their configuration to set the correct visibility according to the documentation. The visibility must be at the same level as `type`. When the Storage is saved on Amazon AWS we recommending disabling public access to the bucket containing the private files: https://docs.aws.amazon.com/AmazonS3/latest/userguide/access-control-block-public-access.html. Otherwise, update to Shopware 6.4.1.1 or install or update the Security plugin (https://store.shopware.com/en/detail/index/sArticle/518463/number/Swag136939272659) and run the command `./bin/console s3:set-visibility` to correct your cloud file visibilities.

Weakness: CWE-732 (Incorrect Permission Assignment for Critical Resource), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2021-32717?

6 open source packages ship an affected version, including shopware/platform and shopware/core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `shopware/platform` | Packagist | All versions | 6.4.1.1 |
| `shopware/platform` | Packagist | All versions | 6.4.1.1 |
| `shopware/platform` | Packagist | All versions | 6.4.1.1 |
| `shopware/platform` | Packagist | All versions | 6.4.1.1 |
| `shopware/core` | Packagist | All versions | 6.4.1.1 |
| `shopware/core` | Packagist | All versions | 6.4.1.1 |

Products: Shopware Shopware.

## How do I fix CVE-2021-32717?

Upgrade shopware/platform to 6.4.1.1 or later.

## Is CVE-2021-32717 being exploited?

There is no known exploitation of CVE-2021-32717 in the wild and no public exploit code.

## Other vulnerabilities in Shopware Shopware

- [CVE-2023-22731](https://insights.sbomify.com/CVE-2023-22731/): Improper Control of Generation of Code in Twig rendered views in shopware (critical 10.0)
- [CVE-2016-3109](https://insights.sbomify.com/CVE-2016-3109/): Shopware RCE Vulnerability (critical 9.8)
- [CVE-2024-22406](https://insights.sbomify.com/CVE-2024-22406/): Blind SQL-injection in DAL aggregations in Shopware (critical 9.3)
- [CVE-2021-32711](https://insights.sbomify.com/CVE-2021-32711/): Leak of information via Store-API (critical 9.1)
- [CVE-2026-31887](https://insights.sbomify.com/CVE-2026-31887/): Shopware unauthenticated data extraction possible through store-api.order endpoint (high 8.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-32717 and fix it if it is affected.

What it is: CVE-2021-32717 is a high-severity vulnerability in Shopware Shopware, published on 24 Jun 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-32717 in the wild and no public exploit code.

Affected packages and fixed versions:
- shopware/platform (Packagist): affected all versions; fixed in 6.4.1.1
- shopware/platform (Packagist): affected all versions; fixed in 6.4.1.1
- shopware/platform (Packagist): affected all versions; fixed in 6.4.1.1
- shopware/platform (Packagist): affected all versions; fixed in 6.4.1.1
- shopware/core (Packagist): affected all versions; fixed in 6.4.1.1
- shopware/core (Packagist): affected all versions; fixed in 6.4.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-32717/ (Markdown: https://insights.sbomify.com/CVE-2021-32717/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-32717
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-32717
- OSV: https://osv.dev/vulnerability/CVE-2021-32717

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-32717/
Summaries are generated and may contain mistakes; the official description above is the record.
