{"answers":{"affected":"1 open source package ship an affected version, including rabbitmq. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-32718 in the wild and no public exploit code.","fix":"Upgrade rabbitmq to 3.8.17 or later.","what":"CVE-2021-32718 is a low-severity cross-site scripting vulnerability in rabbitmq-server, published on 28 Jun 2021. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2021-32718 and fix it if it is affected.\n\nWhat it is: CVE-2021-32718 is a low-severity cross-site scripting vulnerability in rabbitmq-server, published on 28 Jun 2021. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2021-32718 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- rabbitmq (Bitnami): affected all versions; fixed in 3.8.17\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-32718/ (Markdown: https://insights.sbomify.com/CVE-2021-32718/index.md)","id":"CVE-2021-32718","markdown":"https://insights.sbomify.com/CVE-2021-32718/index.md","name":"CVE-2021-32718","record":{"aliases":["BIT-rabbitmq-2021-32718","DEBIAN-CVE-2021-32718","GHSA-c3hj-rg5h-2772","RHSA-2022:8867","UBUNTU-CVE-2021-32718"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"RabbitMQ management UI","requires_auth":"high_privilege","summary":"An authenticated user with elevated permissions can execute arbitrary JavaScript in the RabbitMQ management UI via unsanitized user names.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"rabbitmq","vendor":"vmware"}],"cvss":{"score":3.1,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:U/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"},{"id":"CWE-80","name":"Improper Neutralization of Script-Related HTML Tags in a Web Page"}],"description":"RabbitMQ is a multi-protocol messaging broker. In rabbitmq-server prior to version 3.8.17, a new user being added via management UI could lead to the user's bane being rendered in a confirmation message without proper `\u003cscript\u003e` tag sanitization, potentially allowing for JavaScript code execution in the context of the page. In order for this to occur, the user must be signed in and have elevated permissions (other user management). The vulnerability is patched in RabbitMQ 3.8.17. As a workaround, disable `rabbitmq_management` plugin and use CLI tools for management operations and Prometheus and Grafana for metrics and monitoring.","ecosystems":["Bitnami","Red Hat:openstack:16.1::el8"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Improper Neutralization of Script-Related HTML Tags in a Web Page (Basic XSS) in RabbitMQ management UI","id":"CVE-2021-32718","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"xss","year":"2021"},"n_packages":2,"n_references":3,"next":{"headline":"Improper Neutralization of Script-Related HTML Tags in a Web Page (Basic XSS) in RabbitMQ federation management plugin","id":"CVE-2021-32719"},"packages":[{"ecosystem":"Bitnami","fixed":["3.8.17"],"introduced":["0"],"last_affected":[],"package":"rabbitmq","purl":"pkg:bitnami/rabbitmq","source":"BIT-rabbitmq-2021-32718"},{"ecosystem":"Red Hat:openstack:16.1::el8","fixed":["0:3.7.23-9.el8ost"],"introduced":["0"],"last_affected":[],"package":"rabbitmq-server","purl":"pkg:rpm/redhat/rabbitmq-server","source":"RHSA-2022:8867"}],"prev":{"headline":"Private files publicly accessible with Cloud Storage providers","id":"CVE-2021-32717"},"products":["rabbitmq-server"],"published":"2021-06-28","related":[{"cvss_score":4.9,"headline":"Denial of Service by publishing large messages over the HTTP API","id":"CVE-2023-46118","kev_date_added":null,"published":"2023-10-24"},{"cvss_score":3.1,"headline":"Improper Neutralization of Script-Related HTML Tags in a Web Page (Basic XSS) in RabbitMQ federation management plugin","id":"CVE-2021-32719","kev_date_added":null,"published":"2021-06-28"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"Red Hat","prefix":"RHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["rabbitmq"]},"summary":"An authenticated user with elevated permissions can execute arbitrary JavaScript in the RabbitMQ management UI via unsanitized user names.","url":"https://insights.sbomify.com/CVE-2021-32718/"}