{"answers":{"affected":"2 open source packages ship an affected version, including prismjs. It affects 2 products.","exploited":"There is no known exploitation of CVE-2021-32723 in the wild and no public exploit code.","fix":"Upgrade prismjs to 1.24.0 or later.","what":"CVE-2021-32723 is a high-severity denial of service vulnerability in PrismJS prism, published on 28 Jun 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2021-32723 and fix it if it is affected.\n\nWhat it is: CVE-2021-32723 is a high-severity denial of service vulnerability in PrismJS prism, published on 28 Jun 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2021-32723 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- prismjs (npm): affected all versions; fixed in 1.24.0\n- prismjs (npm): affected all versions; fixed in 1.24.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-32723/ (Markdown: https://insights.sbomify.com/CVE-2021-32723/index.md)","id":"CVE-2021-32723","markdown":"https://insights.sbomify.com/CVE-2021-32723/index.md","name":"CVE-2021-32723","record":{"aliases":["GHSA-gj77-59wh-66hg","ROOT-APP-NPM-CVE-2021-32723","UBUNTU-CVE-2021-32723"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"JavaScript syntax highlighting library","requires_auth":"none","summary":"Attackers can cause denial of service in Prism syntax highlighting library by crafting malicious strings for specific languages.","user_interaction":"required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"application_express","vendor":"oracle"},{"product":"prism","vendor":"prismjs"}],"cvss":{"score":7.4,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-400","name":"Uncontrolled Resource Consumption"}],"description":"Prism is a syntax highlighting library. Some languages before 1.24.0 are vulnerable to Regular Expression Denial of Service (ReDoS). When Prism is used to highlight untrusted (user-given) text, an attacker can craft a string that will take a very very long time to highlight. This problem has been fixed in Prism v1.24. As a workaround, do not use ASCIIDoc or ERB to highlight untrusted text. Other languages are not affected and can be used to highlight untrusted text.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Regular Expression Denial of Service (ReDoS) in Prism","id":"CVE-2021-32723","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2021"},"n_packages":2,"n_references":4,"next":{"headline":"check-spelling workflow vulnerable to GITHUB_TOKEN leakage via symlink attack","id":"CVE-2021-32724"},"packages":[{"ecosystem":"npm","fixed":["1.24.0"],"introduced":["0"],"last_affected":[],"package":"prismjs","purl":null,"source":"GHSA-gj77-59wh-66hg"},{"ecosystem":"npm","fixed":["1.24.0"],"introduced":["0"],"last_affected":[],"package":"prismjs","purl":"pkg:npm/prismjs","source":"GHSA-gj77-59wh-66hg"}],"prev":{"headline":"Uncontrolled Resource Consumption in GlobalNewFiles","id":"CVE-2021-32722"},"products":["prism"],"published":"2021-06-28","related":[{"cvss_score":10,"headline":"Other in n/a","id":"CVE-2008-1822","kev_date_added":null,"published":"2008-04-16"},{"cvss_score":9,"headline":"Open redirect in Oracle Application Express","id":"CVE-2025-50067","kev_date_added":null,"published":"2025-07-15"},{"cvss_score":9,"headline":"Cross-site scripting in Application Express (APEX)","id":"CVE-2023-21974","kev_date_added":null,"published":"2023-07-18"},{"cvss_score":9,"headline":"Cross-site scripting in Application Express (APEX)","id":"CVE-2023-21975","kev_date_added":null,"published":"2023-07-18"},{"cvss_score":6.1,"headline":"Cross-site scripting in Application Express","id":"CVE-2018-2699","kev_date_added":null,"published":"2018-01-18"},{"cvss_score":6.1,"headline":"Information disclosure in n/a","id":"CVE-2016-3448","kev_date_added":null,"published":"2016-07-21"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["PrismJS"]},"summary":"Attackers can cause denial of service in Prism syntax highlighting library by crafting malicious strings for specific languages.","url":"https://insights.sbomify.com/CVE-2021-32723/"}