# CVE-2021-32723: Regular Expression Denial of Service (ReDoS) in Prism

> Attackers can cause denial of service in Prism syntax highlighting library by crafting malicious strings for specific languages.

- **Severity:** High 7.4 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 28 Jun 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-gj77-59wh-66hg, ROOT-APP-NPM-CVE-2021-32723, UBUNTU-CVE-2021-32723

## What is CVE-2021-32723?

CVE-2021-32723 is a high-severity denial of service vulnerability in PrismJS prism, published on 28 Jun 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Prism is a syntax highlighting library. Some languages before 1.24.0 are vulnerable to Regular Expression Denial of Service (ReDoS). When Prism is used to highlight untrusted (user-given) text, an attacker can craft a string that will take a very very long time to highlight. This problem has been fixed in Prism v1.24. As a workaround, do not use ASCIIDoc or ERB to highlight untrusted text. Other languages are not affected and can be used to highlight untrusted text.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2021-32723?

2 open source packages ship an affected version, including prismjs. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `prismjs` | npm | All versions | 1.24.0 |
| `prismjs` | npm | All versions | 1.24.0 |

Products: Oracle Application Express, Prismjs Prism.

## How do I fix CVE-2021-32723?

Upgrade prismjs to 1.24.0 or later.

## Is CVE-2021-32723 being exploited?

There is no known exploitation of CVE-2021-32723 in the wild and no public exploit code.

## Other vulnerabilities in PrismJS prism

- [CVE-2008-1822](https://insights.sbomify.com/CVE-2008-1822/): Other in n/a (critical 10.0)
- [CVE-2025-50067](https://insights.sbomify.com/CVE-2025-50067/): Open redirect in Oracle Application Express (critical 9.0)
- [CVE-2023-21974](https://insights.sbomify.com/CVE-2023-21974/): Cross-site scripting in Application Express (APEX) (critical 9.0)
- [CVE-2023-21975](https://insights.sbomify.com/CVE-2023-21975/): Cross-site scripting in Application Express (APEX) (critical 9.0)
- [CVE-2018-2699](https://insights.sbomify.com/CVE-2018-2699/): Cross-site scripting in Application Express (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-32723 and fix it if it is affected.

What it is: CVE-2021-32723 is a high-severity denial of service vulnerability in PrismJS prism, published on 28 Jun 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2021-32723 in the wild and no public exploit code.

Affected packages and fixed versions:
- prismjs (npm): affected all versions; fixed in 1.24.0
- prismjs (npm): affected all versions; fixed in 1.24.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-32723/ (Markdown: https://insights.sbomify.com/CVE-2021-32723/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-32723
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-32723
- OSV: https://osv.dev/vulnerability/CVE-2021-32723

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-32723/
Summaries are generated and may contain mistakes; the official description above is the record.
