# CVE-2021-32728: End-to-end encryption device setup did not verify public key

> Attackers can decrypt end-to-end encrypted files by serving malicious public keys during device setup in the Nextcloud Desktop Client.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Aug 2021
- **Updated:** 3 Aug 2024
- **Also known as:** DEBIAN-CVE-2021-32728, GHSA-f5fr-5gcv-6cc5, UBUNTU-CVE-2021-32728

## What is CVE-2021-32728?

CVE-2021-32728 is a medium-severity vulnerability in Debian Debian Linux, published on 18 Aug 2021. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

The Nextcloud Desktop Client is a tool to synchronize files from Nextcloud Server with a computer. Clients using the Nextcloud end-to-end encryption feature download the public and private key via an API endpoint. In versions prior to 3.3.0, the Nextcloud Desktop client fails to check if a private key belongs to previously downloaded public certificate. If the Nextcloud instance serves a malicious public key, the data would be encrypted for this key and thus could be accessible to a malicious actor. This issue is fixed in Nextcloud Desktop Client version 3.3.0. There are no known workarounds aside from upgrading.

Weakness: CWE-295 (Improper Certificate Validation)

## Which versions are affected by CVE-2021-32728?

It affects 2 products.


Products: Debian Debian Linux, Nextcloud Desktop.

## How do I fix CVE-2021-32728?

Upgrade to a fixed version.

## Is CVE-2021-32728 being exploited?

There is no known exploitation of CVE-2021-32728 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-32728 and fix it if it is affected.

What it is: CVE-2021-32728 is a medium-severity vulnerability in Debian Debian Linux, published on 18 Aug 2021. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-32728 in the wild and no public exploit code.

Affected product: Debian Debian Linux. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-32728/ (Markdown: https://insights.sbomify.com/CVE-2021-32728/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-32728
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-32728
- OSV: https://osv.dev/vulnerability/CVE-2021-32728

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-32728/
Summaries are generated and may contain mistakes; the official description above is the record.
