CVE-2021-32729 A user without PR can reset user authentication failures information
Attackers with script rights can reset authentication failure records, bypassing brute-force protection mechanisms in XWiki Platform.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2021-32729?
CVE-2021-32729 is a low-severity vulnerability in Xwiki Xwiki, published on 1 Jul 2021. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Official description
XWiki Platform is a generic wiki platform offering runtime services for applications built on top of it. A vulnerability exists in versions prior to 12.6.88, 12.10.4, and 13.0. The script service method used to reset the authentication failures record can be executed by any user with Script rights and does not require Programming rights. An attacher with script rights who is able to reset the authentication failure record might perform a brute force attack, since they would be able to virtually deactivate the mechanism introduced to mitigate those attacks. The problem has been patched in version 12.6.8, 12.10.4 and 13.0. There are no workarounds aside from upgrading.
Which versions are affected by CVE-2021-32729?
4 open source packages ship an affected version, including org.xwiki.platform:xwiki-platform-security-authentication-script. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.xwiki.platform:xwiki-platform-security-authentication-script Maven | From 11.6 | 12.6.8 |
org.xwiki.platform:xwiki-platform-security-authentication-script Maven | From 11.6 | 12.6.8 |
org.xwiki.platform:xwiki-platform-security-authentication-script Maven | From 12.7 | 12.10.4 |
org.xwiki.platform:xwiki-platform-security-authentication-script Maven | From 12.7 | 12.10.4 |
Products include Xwiki Xwiki.
How do I fix CVE-2021-32729?
Upgrade org.xwiki.platform:xwiki-platform-security-authentication-script to a fixed version for your release line: 12.6.8 or 12.10.4.
Is CVE-2021-32729 being exploited?
There is no known exploitation of CVE-2021-32729 in the wild and no public exploit code.
Other vulnerabilities in Xwiki Xwiki
- CVE-2025-24893 XWiki Platform Eval Injection
- CVE-2025-53836 XWiki Rendering is vulnerable to RCE attacks when processing nested macros
- CVE-2024-55662 XWiki allows remote code execution through the extension sheet
- CVE-2024-55877 XWiki allows remote code execution from account through macro descriptions and XWiki.XWikiSyntaxMacrosList
- CVE-2024-37901 XWiki Platform vulnerable to remote code execution from account via SearchSuggestConfigSheet
Sources
Also known as GHSA-m738-3rc4-5xv3.