# CVE-2021-32729: A user without PR can reset user authentication failures information

> Attackers with script rights can reset authentication failure records, bypassing brute-force protection mechanisms in XWiki Platform.

- **Severity:** Low 2.0 (`CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 1 Jul 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-m738-3rc4-5xv3

## What is CVE-2021-32729?

CVE-2021-32729 is a low-severity vulnerability in Xwiki Xwiki, published on 1 Jul 2021. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

XWiki Platform is a generic wiki platform offering runtime services for applications built on top of it. A vulnerability exists in versions prior to 12.6.88, 12.10.4, and 13.0. The script service method used to reset the authentication failures record can be executed by any user with Script rights and does not require Programming rights. An attacher with script rights who is able to reset the authentication failure record might perform a brute force attack, since they would be able to virtually deactivate the mechanism introduced to mitigate those attacks. The problem has been patched in version 12.6.8, 12.10.4 and 13.0. There are no workarounds aside from upgrading.

Weakness: CWE-732 (Incorrect Permission Assignment for Critical Resource), CWE-693 (Protection Mechanism Failure)

## Which versions are affected by CVE-2021-32729?

4 open source packages ship an affected version, including org.xwiki.platform:xwiki-platform-security-authentication-script. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.xwiki.platform:xwiki-platform-security-authentication-script` | Maven | From 11.6 | 12.6.8 |
| `org.xwiki.platform:xwiki-platform-security-authentication-script` | Maven | From 11.6 | 12.6.8 |
| `org.xwiki.platform:xwiki-platform-security-authentication-script` | Maven | From 12.7 | 12.10.4 |
| `org.xwiki.platform:xwiki-platform-security-authentication-script` | Maven | From 12.7 | 12.10.4 |

Products: Xwiki Xwiki.

## How do I fix CVE-2021-32729?

Upgrade org.xwiki.platform:xwiki-platform-security-authentication-script to a fixed version for your release line: 12.6.8 or 12.10.4.

## Is CVE-2021-32729 being exploited?

There is no known exploitation of CVE-2021-32729 in the wild and no public exploit code.

## Other vulnerabilities in Xwiki Xwiki

- [CVE-2025-24893](https://insights.sbomify.com/CVE-2025-24893/): XWiki Platform Eval Injection (critical 9.8, exploited in the wild)
- [CVE-2025-53836](https://insights.sbomify.com/CVE-2025-53836/): XWiki Rendering is vulnerable to RCE attacks when processing nested macros (critical 10.0)
- [CVE-2024-55662](https://insights.sbomify.com/CVE-2024-55662/): XWiki allows remote code execution through the extension sheet (critical 10.0)
- [CVE-2024-55877](https://insights.sbomify.com/CVE-2024-55877/): XWiki allows remote code execution from account through macro descriptions and XWiki.XWikiSyntaxMacrosList (critical 10.0)
- [CVE-2024-37901](https://insights.sbomify.com/CVE-2024-37901/): XWiki Platform vulnerable to remote code execution from account via SearchSuggestConfigSheet (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-32729 and fix it if it is affected.

What it is: CVE-2021-32729 is a low-severity vulnerability in Xwiki Xwiki, published on 1 Jul 2021. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2021-32729 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.xwiki.platform:xwiki-platform-security-authentication-script (Maven): affected from 11.6; fixed in 12.6.8
- org.xwiki.platform:xwiki-platform-security-authentication-script (Maven): affected from 11.6; fixed in 12.6.8
- org.xwiki.platform:xwiki-platform-security-authentication-script (Maven): affected from 12.7; fixed in 12.10.4
- org.xwiki.platform:xwiki-platform-security-authentication-script (Maven): affected from 12.7; fixed in 12.10.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-32729/ (Markdown: https://insights.sbomify.com/CVE-2021-32729/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-32729
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-32729
- OSV: https://osv.dev/vulnerability/CVE-2021-32729

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-32729/
Summaries are generated and may contain mistakes; the official description above is the record.
