# CVE-2021-32730: No CSRF protection on the password change form

> An attacker can trick an admin into resetting any user's password via a forged URL, leading to account takeover.

- **Severity:** Medium 5.7 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 1 Jul 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-v9j2-q4q5-cxh4

## What is CVE-2021-32730?

CVE-2021-32730 is a medium-severity vulnerability in Xwiki Xwiki, published on 1 Jul 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

XWiki Platform is a generic wiki platform offering runtime services for applications built on top of it. A cross-site request forgery vulnerability exists in versions prior to 12.10.5, and in versions 13.0 through 13.1. It's possible for forge an URL that, when accessed by an admin, will reset the password of any user in XWiki. The problem has been patched in XWiki 12.10.5 and 13.2RC1. As a workaround, it is possible to apply the patch manually by modifying the `register_macros.vm` template.

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2021-32730?

4 open source packages ship an affected version, including org.xwiki.platform:xwiki-platform-administration-ui. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.xwiki.platform:xwiki-platform-administration-ui` | Maven | All versions | 12.10.5 |
| `org.xwiki.platform:xwiki-platform-administration-ui` | Maven | All versions | 12.10.5 |
| `org.xwiki.platform:xwiki-platform-administration-ui` | Maven | From 13.0 | 13.2 |
| `org.xwiki.platform:xwiki-platform-administration-ui` | Maven | From 13.0 | 13.2 |

Products: Xwiki Xwiki.

## How do I fix CVE-2021-32730?

Upgrade org.xwiki.platform:xwiki-platform-administration-ui to a fixed version for your release line: 12.10.5 or 13.2.

## Is CVE-2021-32730 being exploited?

There is no known exploitation of CVE-2021-32730 in the wild and no public exploit code.

## Other vulnerabilities in Xwiki Xwiki

- [CVE-2025-24893](https://insights.sbomify.com/CVE-2025-24893/): XWiki Platform Eval Injection (critical 9.8, exploited in the wild)
- [CVE-2025-53836](https://insights.sbomify.com/CVE-2025-53836/): XWiki Rendering is vulnerable to RCE attacks when processing nested macros (critical 10.0)
- [CVE-2024-55662](https://insights.sbomify.com/CVE-2024-55662/): XWiki allows remote code execution through the extension sheet (critical 10.0)
- [CVE-2024-55877](https://insights.sbomify.com/CVE-2024-55877/): XWiki allows remote code execution from account through macro descriptions and XWiki.XWikiSyntaxMacrosList (critical 10.0)
- [CVE-2024-37901](https://insights.sbomify.com/CVE-2024-37901/): XWiki Platform vulnerable to remote code execution from account via SearchSuggestConfigSheet (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-32730 and fix it if it is affected.

What it is: CVE-2021-32730 is a medium-severity vulnerability in Xwiki Xwiki, published on 1 Jul 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2021-32730 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.xwiki.platform:xwiki-platform-administration-ui (Maven): affected all versions; fixed in 12.10.5
- org.xwiki.platform:xwiki-platform-administration-ui (Maven): affected all versions; fixed in 12.10.5
- org.xwiki.platform:xwiki-platform-administration-ui (Maven): affected from 13.0; fixed in 13.2
- org.xwiki.platform:xwiki-platform-administration-ui (Maven): affected from 13.0; fixed in 13.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-32730/ (Markdown: https://insights.sbomify.com/CVE-2021-32730/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-32730
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-32730
- OSV: https://osv.dev/vulnerability/CVE-2021-32730

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-32730/
Summaries are generated and may contain mistakes; the official description above is the record.
