{"answers":{"affected":"2 open source packages ship an affected version, including getkirby/cms. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-32735 in the wild and no public exploit code.","fix":"Upgrade getkirby/cms to 3.5.7 or later.","what":"CVE-2021-32735 is a high-severity cross-site scripting vulnerability in getkirby kirby, published on 2 Jul 2021. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2021-32735 and fix it if it is affected.\n\nWhat it is: CVE-2021-32735 is a high-severity cross-site scripting vulnerability in getkirby kirby, published on 2 Jul 2021. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2021-32735 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- getkirby/cms (Packagist): affected all versions; fixed in 3.5.7\n- getkirby/cms (Packagist): affected all versions; fixed in 3.5.7\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-32735/ (Markdown: https://insights.sbomify.com/CVE-2021-32735/index.md)","id":"CVE-2021-32735","markdown":"https://insights.sbomify.com/CVE-2021-32735/index.md","name":"CVE-2021-32735","record":{"aliases":["GHSA-2f2w-349x-vrqm"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["privilege_escalation","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Kirby CMS","requires_auth":"low_privilege","summary":"Authenticated users or frontend visitors can inject scripts via page titles in the Kirby CMS Panel, potentially escalating privileges or hijacking admin sessions.","user_interaction":"not_required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"kirby","vendor":"getkirby"}],"cvss":{"score":7.1,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"},{"id":"CWE-80","name":"Improper Neutralization of Script-Related HTML Tags in a Web Page"}],"description":"Kirby is a content management system. In Kirby CMS versions 3.5.5 and 3.5.6, the Panel's `ListItem` component (used in the pages and files section for example) displayed HTML in page titles as it is. This could be used for cross-site scripting (XSS) attacks. Malicious authenticated Panel users can escalate their privileges if they get access to the Panel session of an admin user. Visitors without Panel access can use the attack vector if the site allows changing site data from a frontend form. Kirby 3.5.7 patches the vulnerability. As a partial workaround, site administrators can protect against attacks from visitors without Panel access by validating or sanitizing provided data from the frontend form.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Cross-site scripting (XSS) from field and configuration text displayed in the Panel","id":"CVE-2021-32735","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2021"},"n_packages":2,"n_references":2,"next":{"headline":"Improperly Controlled Modification of Object Prototype Attributes ('Prototype Pollution') in think-helper","id":"CVE-2021-32736"},"packages":[{"ecosystem":"Packagist","fixed":["3.5.7"],"introduced":["0"],"last_affected":[],"package":"getkirby/cms","purl":null,"source":"GHSA-2f2w-349x-vrqm"},{"ecosystem":"Packagist","fixed":["3.5.7"],"introduced":["0"],"last_affected":[],"package":"getkirby/cms","purl":"pkg:composer/getkirby/cms","source":"GHSA-2f2w-349x-vrqm"}],"prev":{"headline":"File path disclosure of shared files in Nextcloud Text application","id":"CVE-2021-32734"},"products":["kirby"],"published":"2021-07-02","related":[{"cvss_score":8.8,"headline":"Kirby vulnerable to unrestricted file upload of user avatar images","id":"CVE-2024-26483","kev_date_added":null,"published":"2024-02-22"},{"cvss_score":8.1,"headline":"Insufficient permission checks in the language settings in Kirby CMS","id":"CVE-2024-41964","kev_date_added":null,"published":"2024-08-29"},{"cvss_score":7.6,"headline":"Kirby has Server-Side Template Injection (SSTI) via double template resolution in option rendering","id":"CVE-2026-34587","kev_date_added":null,"published":"2026-04-24"},{"cvss_score":7.6,"headline":"Cross-site scripting (XSS) from unsanitized uploaded SVG files","id":"CVE-2021-29460","kev_date_added":null,"published":"2021-04-27"},{"cvss_score":7.3,"headline":"Kirby vulnerable to Insufficient Session Expiration after a password change","id":"CVE-2023-38489","kev_date_added":null,"published":"2023-07-27"},{"cvss_score":7.3,"headline":"Cross-site scripting (XSS) from writer field content in the site frontend","id":"CVE-2021-41252","kev_date_added":null,"published":"2021-11-16"},{"cvss_score":7.3,"headline":"Cross-site scripting (XSS) from image block content in the site frontend","id":"CVE-2021-41258","kev_date_added":null,"published":"2021-11-16"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["getkirby"]},"summary":"Authenticated users or frontend visitors can inject scripts via page titles in the Kirby CMS Panel, potentially escalating privileges or hijacking admin sessions.","url":"https://insights.sbomify.com/CVE-2021-32735/"}