# CVE-2021-32735: Cross-site scripting (XSS) from field and configuration text displayed in the Panel

> Authenticated users or frontend visitors can inject scripts via page titles in the Kirby CMS Panel, potentially escalating privileges or hijacking admin sessions.

- **Severity:** High 7.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Jul 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-2f2w-349x-vrqm

## What is CVE-2021-32735?

CVE-2021-32735 is a high-severity cross-site scripting vulnerability in getkirby kirby, published on 2 Jul 2021. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Kirby is a content management system. In Kirby CMS versions 3.5.5 and 3.5.6, the Panel's `ListItem` component (used in the pages and files section for example) displayed HTML in page titles as it is. This could be used for cross-site scripting (XSS) attacks. Malicious authenticated Panel users can escalate their privileges if they get access to the Panel session of an admin user. Visitors without Panel access can use the attack vector if the site allows changing site data from a frontend form. Kirby 3.5.7 patches the vulnerability. As a partial workaround, site administrators can protect against attacks from visitors without Panel access by validating or sanitizing provided data from the frontend form.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation), CWE-80 (Improper Neutralization of Script-Related HTML Tags in a Web Page)

## Which versions are affected by CVE-2021-32735?

2 open source packages ship an affected version, including getkirby/cms. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `getkirby/cms` | Packagist | All versions | 3.5.7 |
| `getkirby/cms` | Packagist | All versions | 3.5.7 |

Products: Getkirby Kirby.

## How do I fix CVE-2021-32735?

Upgrade getkirby/cms to 3.5.7 or later.

## Is CVE-2021-32735 being exploited?

There is no known exploitation of CVE-2021-32735 in the wild and no public exploit code.

## Other vulnerabilities in getkirby kirby

- [CVE-2024-26483](https://insights.sbomify.com/CVE-2024-26483/): Kirby vulnerable to unrestricted file upload of user avatar images (high 8.8)
- [CVE-2024-41964](https://insights.sbomify.com/CVE-2024-41964/): Insufficient permission checks in the language settings in Kirby CMS (high 8.1)
- [CVE-2026-34587](https://insights.sbomify.com/CVE-2026-34587/): Kirby has Server-Side Template Injection (SSTI) via double template resolution in option rendering (high 7.6)
- [CVE-2021-29460](https://insights.sbomify.com/CVE-2021-29460/): Cross-site scripting (XSS) from unsanitized uploaded SVG files (high 7.6)
- [CVE-2023-38489](https://insights.sbomify.com/CVE-2023-38489/): Kirby vulnerable to Insufficient Session Expiration after a password change (high 7.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-32735 and fix it if it is affected.

What it is: CVE-2021-32735 is a high-severity cross-site scripting vulnerability in getkirby kirby, published on 2 Jul 2021. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-32735 in the wild and no public exploit code.

Affected packages and fixed versions:
- getkirby/cms (Packagist): affected all versions; fixed in 3.5.7
- getkirby/cms (Packagist): affected all versions; fixed in 3.5.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-32735/ (Markdown: https://insights.sbomify.com/CVE-2021-32735/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-32735
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-32735
- OSV: https://osv.dev/vulnerability/CVE-2021-32735

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-32735/
Summaries are generated and may contain mistakes; the official description above is the record.
