{"answers":{"affected":"2 open source packages ship an affected version, including addressable. It affects 2 products.","exploited":"There is no known exploitation of CVE-2021-32740 in the wild and no public exploit code.","fix":"Upgrade addressable to 2.8.0 or later.","what":"CVE-2021-32740 is a high-severity denial of service vulnerability in Fedoraproject Fedora, published on 6 Jul 2021. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2021-32740 and fix it if it is affected.\n\nWhat it is: CVE-2021-32740 is a high-severity denial of service vulnerability in Fedoraproject Fedora, published on 6 Jul 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2021-32740 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- addressable (RubyGems): affected from 2.3.0; fixed in 2.8.0\n- addressable (RubyGems): affected from 2.3.0; fixed in 2.8.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-32740/ (Markdown: https://insights.sbomify.com/CVE-2021-32740/index.md)","id":"CVE-2021-32740","markdown":"https://insights.sbomify.com/CVE-2021-32740/index.md","name":"CVE-2021-32740","record":{"aliases":["DEBIAN-CVE-2021-32740","GHSA-jxhc-q857-3j6g","MGASA-2021-0417","OESA-2021-1278","SUSE-SU-2021:2927-1","SUSE-SU-2021:2928-1","UBUNTU-CVE-2021-32740","openSUSE-SU-2024:11592-1","openSUSE-SU-2024:12247-1","openSUSE-SU-2024:13157-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Ruby URI library","requires_auth":"none","summary":"Attackers can cause denial of service in the Addressable Ruby library by providing maliciously crafted URI templates that trigger excessive resource consumption.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"addressable","vendor":"addressable_project"},{"product":"fedora","vendor":"fedoraproject"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-400","name":"Uncontrolled Resource Consumption"}],"description":"Addressable is an alternative implementation to the URI implementation that is part of Ruby's standard library. An uncontrolled resource consumption vulnerability exists after version 2.3.0 through version 2.7.0. Within the URI template implementation in Addressable, a maliciously crafted template may result in uncontrolled resource consumption, leading to denial of service when matched against a URI. In typical usage, templates would not normally be read from untrusted user input, but nonetheless, no previous security advisory for Addressable has cautioned against doing this. Users of the parsing capabilities in Addressable but not the URI template capabilities are unaffected. The vulnerability is patched in version 2.8.0. As a workaround, only create Template objects from trusted sources that have been validated not to produce catastrophic backtracking.","ecosystems":["RubyGems","SUSE:OpenStack Cloud Crowbar 8","SUSE:OpenStack Cloud Crowbar 9","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Regular Expression Denial of Service in Addressable templates","id":"CVE-2021-32740","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":"fedoraproject:fedora","products":["fedoraproject:fedora"],"type":"denial_of_service","year":"2021"},"n_packages":6,"n_references":4,"next":{"headline":"Lack of ratelimit on public share link mount endpoint","id":"CVE-2021-32741"},"packages":[{"ecosystem":"RubyGems","fixed":["2.8.0"],"introduced":["2.3.0"],"last_affected":[],"package":"addressable","purl":null,"source":"GHSA-jxhc-q857-3j6g"},{"ecosystem":"RubyGems","fixed":["2.8.0"],"introduced":["2.3.0"],"last_affected":[],"package":"addressable","purl":"pkg:gem/addressable","source":"GHSA-jxhc-q857-3j6g"},{"ecosystem":"SUSE:OpenStack Cloud Crowbar 8","fixed":["2.3.6-3.3.3"],"introduced":["0"],"last_affected":[],"package":"rubygem-addressable","purl":"pkg:rpm/suse/rubygem-addressable\u0026distro=SUSE%20OpenStack%20Cloud%20Crowbar%208","source":"SUSE-SU-2021:2928-1"},{"ecosystem":"SUSE:OpenStack Cloud Crowbar 9","fixed":["2.3.6-4.3.3"],"introduced":["0"],"last_affected":[],"package":"rubygem-addressable","purl":"pkg:rpm/suse/rubygem-addressable\u0026distro=SUSE%20OpenStack%20Cloud%20Crowbar%209","source":"SUSE-SU-2021:2927-1"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["5.1.0-1.4"],"introduced":["0"],"last_affected":[],"package":"ruby3.2-rubygem-http","purl":"pkg:rpm/opensuse/ruby3.2-rubygem-http\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2024:13157-1"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["5.1.0-1.1"],"introduced":["0"],"last_affected":[],"package":"rubygem-http","purl":"pkg:rpm/opensuse/rubygem-http\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2024:12247-1"}],"prev":{"headline":"Information disclosure in icinga2","id":"CVE-2021-32739"},"products":["addressable"],"published":"2021-07-06","related":[{"cvss_score":7.5,"headline":"Addressable has a Regular Expression Denial of Service in Addressable templates","id":"CVE-2026-35611","kev_date_added":null,"published":"2026-04-07"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["sporkmonger"]},"summary":"Attackers can cause denial of service in the Addressable Ruby library by providing maliciously crafted URI templates that trigger excessive resource consumption.","url":"https://insights.sbomify.com/CVE-2021-32740/"}