# CVE-2021-32751: Arbitrary code execution via specially crafted environment variables

> Attackers can execute arbitrary code by manipulating environment variables in Gradle start scripts, affecting developers using Unix-like systems.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Jul 2021
- **Updated:** 8 Oct 2026
- **Also known as:** BIT-gradle-2021-32751, CLEANSTART-2026-BD83881, CLEANSTART-2026-KX40162, DEBIAN-CVE-2021-32751, GHSA-6j2p-252f-7mw8, SUSE-SU-2023:2203-1, UBUNTU-CVE-2021-32751

## What is CVE-2021-32751?

CVE-2021-32751 is a high-severity command injection vulnerability in gradle, published on 20 Jul 2021. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Gradle is a build tool with a focus on build automation. In versions prior to 7.2, start scripts generated by the `application` plugin and the `gradlew` script are both vulnerable to arbitrary code execution when an attacker is able to change environment variables for the user running the script. This may impact those who use `gradlew` on Unix-like systems or use the scripts generated by Gradle in thieir application on Unix-like systems. For this vulnerability to be exploitable, an attacker needs to be able to set the value of particular environment variables and have those environment variables be seen by the vulnerable scripts. This issue has been patched in Gradle 7.2 by removing the use of `eval` and requiring the use of the `bash` shell. There are a few workarounds available. For CI/CD systems using the Gradle build tool, one may ensure that untrusted users are unable to change environment variables for the user that executes `gradlew`. If one is unable to upgrade to Gradle 7.2, one may generate a new `gradlew` script with Gradle 7.2 and use it for older versions of Gradle. Fpplications using start scripts generated by Gradle, one may ensure that untrusted users are unable to change environment variables for the user that executes the start script. A vulnerable start script could be manually patched to remove the use of `eval` or the use of environment variables that affect the application's command-line. If the application is simple enough, one may be able to avoid the use of the start scripts by running the application directly with Java command.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2021-32751?

1 open source package ship an affected version, including gradle. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `gradle` | Bitnami | All versions | 7.2.0 |
| `gradle` | SUSE:Linux Enterprise Module for Development Tools 15 SP4 | All versions | 4.4.1-150200.3.10.1 |
| `gradle` | SUSE:Linux Enterprise Real Time 15 SP3 | All versions | 4.4.1-150200.3.10.1 |
| `gradle` | openSUSE:Leap 15.4 | All versions | 4.4.1-150200.3.10.1 |

Products: Gradle Gradle.

## How do I fix CVE-2021-32751?

Upgrade gradle to 7.2.0 or later.

## Is CVE-2021-32751 being exploited?

There is no known exploitation of CVE-2021-32751 in the wild and no public exploit code.

## Other vulnerabilities in gradle

- [CVE-2019-15052](https://insights.sbomify.com/CVE-2019-15052/): Information disclosure in n/a (critical 9.8)
- [CVE-2016-6199](https://insights.sbomify.com/CVE-2016-6199/): Deserialization in n/a (critical 9.8)
- [CVE-2021-29428](https://insights.sbomify.com/CVE-2021-29428/): Local privilege escalation through system temporary directory (high 8.8)
- [CVE-2026-22816](https://insights.sbomify.com/CVE-2026-22816/): Gradle fails to disable repositories which can expose builds to malicious artifacts (high 8.6)
- [CVE-2026-22865](https://insights.sbomify.com/CVE-2026-22865/): Gradle's failure to disable repositories failing to answer can expose builds to malicious artifacts (high 8.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-32751 and fix it if it is affected.

What it is: CVE-2021-32751 is a high-severity command injection vulnerability in gradle, published on 20 Jul 2021. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-32751 in the wild and no public exploit code.

Affected packages and fixed versions:
- gradle (Bitnami): affected all versions; fixed in 7.2.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-32751/ (Markdown: https://insights.sbomify.com/CVE-2021-32751/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-32751
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-32751
- OSV: https://osv.dev/vulnerability/CVE-2021-32751

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-32751/
Summaries are generated and may contain mistakes; the official description above is the record.
