{"answers":{"affected":"4 open source packages ship an affected version, including openmage/magento-lts. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-32758 in the wild and no public exploit code.","fix":"Upgrade openmage/magento-lts to a fixed version for your release line: 19.4.15 or 20.0.13.","what":"CVE-2021-32758 is a high-severity code injection vulnerability in OpenMage magento-lts, published on 27 Aug 2021. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2021-32758 and fix it if it is affected.\n\nWhat it is: CVE-2021-32758 is a high-severity code injection vulnerability in OpenMage magento-lts, published on 27 Aug 2021. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2021-32758 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- openmage/magento-lts (Packagist): affected all versions; fixed in 19.4.15\n- openmage/magento-lts (Packagist): affected all versions; fixed in 19.4.15\n- openmage/magento-lts (Packagist): affected from 20.0.0; fixed in 20.0.13\n- openmage/magento-lts (Packagist): affected from 20.0.0; fixed in 20.0.13\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-32758/ (Markdown: https://insights.sbomify.com/CVE-2021-32758/index.md)","id":"CVE-2021-32758","markdown":"https://insights.sbomify.com/CVE-2021-32758/index.md","name":"CVE-2021-32758","record":{"aliases":["GHSA-26rr-v2j2-25fh"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"OpenMage Magento LTS","requires_auth":"high_privilege","summary":"Admin users can execute arbitrary commands via layout XML block methods in OpenMage Magento LTS, requiring an upgrade to patched versions.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"openmage","vendor":"openmage"}],"cvss":{"score":7.2,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-91","name":"XML Injection"}],"description":"OpenMage Magento LTS is an alternative to the Magento CE official releases. Prior to versions 19.4.15 and 20.0.11, layout XML enabled admin users to execute arbitrary commands via block methods. The latest OpenMage Versions up from v19.4.15 and v20.0.11 have this Issue patched.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Layout XML Arbitrary Code Fix","id":"CVE-2021-32758","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"code_injection","year":"2021"},"n_packages":4,"n_references":3,"next":{"headline":"Data Flow Sanitation Issue Fix","id":"CVE-2021-32759"},"packages":[{"ecosystem":"Packagist","fixed":["19.4.15"],"introduced":["0"],"last_affected":[],"package":"openmage/magento-lts","purl":null,"source":"GHSA-26rr-v2j2-25fh"},{"ecosystem":"Packagist","fixed":["19.4.15"],"introduced":["0"],"last_affected":[],"package":"openmage/magento-lts","purl":"pkg:composer/openmage/magento-lts","source":"GHSA-26rr-v2j2-25fh"},{"ecosystem":"Packagist","fixed":["20.0.13"],"introduced":["20.0.0"],"last_affected":[],"package":"openmage/magento-lts","purl":null,"source":"GHSA-26rr-v2j2-25fh"},{"ecosystem":"Packagist","fixed":["20.0.13"],"introduced":["20.0.0"],"last_affected":[],"package":"openmage/magento-lts","purl":"pkg:composer/openmage/magento-lts","source":"GHSA-26rr-v2j2-25fh"}],"prev":{"headline":"Arbitrary eval through MiqExpression","id":"CVE-2021-32756"},"products":["magento-lts"],"published":"2021-08-27","related":[{"cvss_score":8.7,"headline":"Widget instances allows a hacker to inject an executable file on the server on OpenMage","id":"CVE-2020-26285","kev_date_added":null,"published":"2021-01-21"},{"cvss_score":8.7,"headline":"CMS Editor code execution","id":"CVE-2020-26295","kev_date_added":null,"published":"2021-01-21"},{"cvss_score":8.7,"headline":"Layout XML RCE Vulnerability in OpenMage","id":"CVE-2020-26252","kev_date_added":null,"published":"2021-01-20"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["OpenMage"]},"summary":"Admin users can execute arbitrary commands via layout XML block methods in OpenMage Magento LTS, requiring an upgrade to patched versions.","url":"https://insights.sbomify.com/CVE-2021-32758/"}