# CVE-2021-32758: Layout XML Arbitrary Code Fix

> Admin users can execute arbitrary commands via layout XML block methods in OpenMage Magento LTS, requiring an upgrade to patched versions.

- **Severity:** High 7.2 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Aug 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-26rr-v2j2-25fh

## What is CVE-2021-32758?

CVE-2021-32758 is a high-severity code injection vulnerability in OpenMage magento-lts, published on 27 Aug 2021. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

OpenMage Magento LTS is an alternative to the Magento CE official releases. Prior to versions 19.4.15 and 20.0.11, layout XML enabled admin users to execute arbitrary commands via block methods. The latest OpenMage Versions up from v19.4.15 and v20.0.11 have this Issue patched.

Weakness: CWE-91 (XML Injection)

## Which versions are affected by CVE-2021-32758?

4 open source packages ship an affected version, including openmage/magento-lts. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `openmage/magento-lts` | Packagist | All versions | 19.4.15 |
| `openmage/magento-lts` | Packagist | All versions | 19.4.15 |
| `openmage/magento-lts` | Packagist | From 20.0.0 | 20.0.13 |
| `openmage/magento-lts` | Packagist | From 20.0.0 | 20.0.13 |

Products: Openmage Openmage.

## How do I fix CVE-2021-32758?

Upgrade openmage/magento-lts to a fixed version for your release line: 19.4.15 or 20.0.13.

## Is CVE-2021-32758 being exploited?

There is no known exploitation of CVE-2021-32758 in the wild and no public exploit code.

## Other vulnerabilities in OpenMage magento-lts

- [CVE-2020-26285](https://insights.sbomify.com/CVE-2020-26285/): Widget instances allows a hacker to inject an executable file on the server on OpenMage (high 8.7)
- [CVE-2020-26295](https://insights.sbomify.com/CVE-2020-26295/): CMS Editor code execution (high 8.7)
- [CVE-2020-26252](https://insights.sbomify.com/CVE-2020-26252/): Layout XML RCE Vulnerability in OpenMage (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-32758 and fix it if it is affected.

What it is: CVE-2021-32758 is a high-severity code injection vulnerability in OpenMage magento-lts, published on 27 Aug 2021. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-32758 in the wild and no public exploit code.

Affected packages and fixed versions:
- openmage/magento-lts (Packagist): affected all versions; fixed in 19.4.15
- openmage/magento-lts (Packagist): affected all versions; fixed in 19.4.15
- openmage/magento-lts (Packagist): affected from 20.0.0; fixed in 20.0.13
- openmage/magento-lts (Packagist): affected from 20.0.0; fixed in 20.0.13

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-32758/ (Markdown: https://insights.sbomify.com/CVE-2021-32758/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-32758
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-32758
- OSV: https://osv.dev/vulnerability/CVE-2021-32758

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-32758/
Summaries are generated and may contain mistakes; the official description above is the record.
