# CVE-2021-32759: Data Flow Sanitation Issue Fix

> Admin users can upload arbitrary executable files due to missing data flow sanitation, potentially leading to remote code execution.

- **Severity:** High 7.2 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Aug 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-xm9f-vxmx-4m58

## What is CVE-2021-32759?

CVE-2021-32759 is a high-severity vulnerability in OpenMage magento-lts, published on 27 Aug 2021. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

OpenMage magento-lts is an alternative to the Magento CE official releases. Due to missing sanitation in data flow in versions prior to 19.4.15 and 20.0.13, it was possible for admin users to upload arbitrary executable files to the server. OpenMage versions 19.4.15 and 20.0.13 have a patch for this Issue.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2021-32759?

4 open source packages ship an affected version, including openmage/magento-lts. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `openmage/magento-lts` | Packagist | All versions | 19.4.15 |
| `openmage/magento-lts` | Packagist | All versions | 19.4.15 |
| `openmage/magento-lts` | Packagist | From 20.0.0 | 20.0.13 |
| `openmage/magento-lts` | Packagist | From 20.0.0 | 20.0.13 |

Products: Openmage Magento.

## How do I fix CVE-2021-32759?

Upgrade openmage/magento-lts to a fixed version for your release line: 19.4.15 or 20.0.13.

## Is CVE-2021-32759 being exploited?

There is no known exploitation of CVE-2021-32759 in the wild and no public exploit code.

## Other vulnerabilities in OpenMage magento-lts

- [CVE-2021-21426](https://insights.sbomify.com/CVE-2021-21426/): Fixes a bug in Zend Framework's Stream HTTP Wrapper (critical 9.8)
- [CVE-2021-21427](https://insights.sbomify.com/CVE-2021-21427/): Backport for CVE-2021-21024 Blind SQLi from Magento 2 (critical 9.1)
- [CVE-2021-41144](https://insights.sbomify.com/CVE-2021-41144/): OpenMage LTS authenticated remote code execution through layout update (high 8.8)
- [CVE-2026-40488](https://insights.sbomify.com/CVE-2026-40488/): OpenMage LTS has Customer File Upload Extension Blocklist Bypass that Leads to Remote Code Execution (high 8.7)
- [CVE-2026-25524](https://insights.sbomify.com/CVE-2026-25524/): OpenMage LTS's Phar Deserialization leads to Remote Code Execution (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-32759 and fix it if it is affected.

What it is: CVE-2021-32759 is a high-severity vulnerability in OpenMage magento-lts, published on 27 Aug 2021. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-32759 in the wild and no public exploit code.

Affected packages and fixed versions:
- openmage/magento-lts (Packagist): affected all versions; fixed in 19.4.15
- openmage/magento-lts (Packagist): affected all versions; fixed in 19.4.15
- openmage/magento-lts (Packagist): affected from 20.0.0; fixed in 20.0.13
- openmage/magento-lts (Packagist): affected from 20.0.0; fixed in 20.0.13

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-32759/ (Markdown: https://insights.sbomify.com/CVE-2021-32759/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-32759
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-32759
- OSV: https://osv.dev/vulnerability/CVE-2021-32759

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-32759/
Summaries are generated and may contain mistakes; the official description above is the record.
