CVE-2021-32760 Archive package allows chmod of file outside of unpack target directory
Attackers can modify host file permissions via crafted container images, potentially enabling privilege escalation or access control bypasses.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2021-32760?
CVE-2021-32760 is a medium-severity vulnerability in Fedoraproject Fedora, published on 19 Jul 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
containerd is a container runtime. A bug was found in containerd versions prior to 1.4.8 and 1.5.4 where pulling and extracting a specially-crafted container image can result in Unix file permission changes for existing files in the host’s filesystem. Changes to file permissions can deny access to the expected owner of the file, widen access to others, or set extended bits like setuid, setgid, and sticky. This bug does not directly allow files to be read, modified, or executed without an additional cooperating process. This bug has been fixed in containerd 1.5.4 and 1.4.8. As a workaround, ensure that users only pull images from trusted sources. Linux security modules (LSMs) like SELinux and AppArmor can limit the files potentially affected by this bug through policies and profiles that prevent containerd from interacting with specific files.
Which versions are affected by CVE-2021-32760?
5 open source packages ship an affected version, including github.com/containerd/containerd. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
github.com/containerd/containerd Go | All versions | 1.4.8, 1.5.4 |
github.com/containerd/containerd Go | All versions | 1.4.8 |
github.com/containerd/containerd Go | All versions | 1.4.8 |
github.com/containerd/containerd Go | From 1.5.0 | 1.5.4 |
github.com/containerd/containerd Go | From 1.5.0 | 1.5.4 |
Linux distribution packages (7)
containerd SUSE:Linux Enterprise Micro 5.0 | All versions | 1.4.4-5.36.1 |
containerd SUSE:Linux Enterprise Module for Containers 12 | All versions | 1.4.4-16.42.1 |
containerd SUSE:Linux Enterprise Module for Containers 15 SP2 | All versions | 1.4.4-5.36.1 |
containerd SUSE:Linux Enterprise Module for Containers 15 SP3 | All versions | 1.4.4-5.36.1 |
containerd openSUSE:Leap 15.2 | All versions | 1.4.4-lp152.2.9.1 |
containerd openSUSE:Leap 15.3 | All versions | 1.4.4-5.36.1 |
trivy openSUSE:Tumbleweed | All versions | 0.20.2-1.1 |
Products include Fedoraproject Fedora, Linuxfoundation Containerd.
How do I fix CVE-2021-32760?
Upgrade github.com/containerd/containerd to a fixed version for your release line: 1.4.8 or 1.5.4.
Is CVE-2021-32760 being exploited?
There is no known exploitation of CVE-2021-32760 in the wild and no public exploit code.
Other vulnerabilities in Fedoraproject Fedora
Sources
Also known as AZL-6680, CLEANSTART-2025-OM13781, DEBIAN-CVE-2021-32760, GHSA-c72p-9xmj-rx3w, GO-2022-0921, SUSE-SU-2021:2412-1 and 6 more.