# CVE-2021-32760: Archive package allows chmod of file outside of unpack target directory

> Attackers can modify host file permissions via crafted container images, potentially enabling privilege escalation or access control bypasses.

- **Severity:** Medium 5.0 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 19 Jul 2021
- **Updated:** 19 Nov 2024
- **Also known as:** AZL-6680, CLEANSTART-2025-OM13781, DEBIAN-CVE-2021-32760, GHSA-c72p-9xmj-rx3w, GO-2022-0921, SUSE-SU-2021:2412-1, SUSE-SU-2021:2413-1, UBUNTU-CVE-2021-32760, USN-5012-1, openSUSE-SU-2021:1081-1, openSUSE-SU-2021:2412-1, openSUSE-SU-2024:11619-1

## What is CVE-2021-32760?

CVE-2021-32760 is a medium-severity vulnerability in Fedoraproject Fedora, published on 19 Jul 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

containerd is a container runtime. A bug was found in containerd versions prior to 1.4.8 and 1.5.4 where pulling and extracting a specially-crafted container image can result in Unix file permission changes for existing files in the host’s filesystem. Changes to file permissions can deny access to the expected owner of the file, widen access to others, or set extended bits like setuid, setgid, and sticky. This bug does not directly allow files to be read, modified, or executed without an additional cooperating process. This bug has been fixed in containerd 1.5.4 and 1.4.8. As a workaround, ensure that users only pull images from trusted sources. Linux security modules (LSMs) like SELinux and AppArmor can limit the files potentially affected by this bug through policies and profiles that prevent containerd from interacting with specific files.

Weakness: CWE-732 (Incorrect Permission Assignment for Critical Resource), CWE-668 (Exposure of Resource to Wrong Sphere)

## Which versions are affected by CVE-2021-32760?

5 open source packages ship an affected version, including github.com/containerd/containerd. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/containerd/containerd` | Go | All versions | 1.4.8, 1.5.4 |
| `github.com/containerd/containerd` | Go | All versions | 1.4.8 |
| `github.com/containerd/containerd` | Go | All versions | 1.4.8 |
| `github.com/containerd/containerd` | Go | From 1.5.0 | 1.5.4 |
| `github.com/containerd/containerd` | Go | From 1.5.0 | 1.5.4 |
| `containerd` | SUSE:Linux Enterprise Micro 5.0 | All versions | 1.4.4-5.36.1 |
| `containerd` | SUSE:Linux Enterprise Module for Containers 12 | All versions | 1.4.4-16.42.1 |
| `containerd` | SUSE:Linux Enterprise Module for Containers 15 SP2 | All versions | 1.4.4-5.36.1 |
| `containerd` | SUSE:Linux Enterprise Module for Containers 15 SP3 | All versions | 1.4.4-5.36.1 |
| `containerd` | openSUSE:Leap 15.2 | All versions | 1.4.4-lp152.2.9.1 |
| `containerd` | openSUSE:Leap 15.3 | All versions | 1.4.4-5.36.1 |
| `trivy` | openSUSE:Tumbleweed | All versions | 0.20.2-1.1 |

Products: Fedoraproject Fedora, Linuxfoundation Containerd.

## How do I fix CVE-2021-32760?

Upgrade github.com/containerd/containerd to a fixed version for your release line: 1.4.8 or 1.5.4.

## Is CVE-2021-32760 being exploited?

There is no known exploitation of CVE-2021-32760 in the wild and no public exploit code.

## Other vulnerabilities in Fedoraproject Fedora

- [CVE-2024-4577](https://insights.sbomify.com/CVE-2024-4577/): PHP-CGI OS Command Injection (critical 9.8, exploited in the wild)
- [CVE-2021-39226](https://insights.sbomify.com/CVE-2021-39226/): Grafana Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2019-5544](https://insights.sbomify.com/CVE-2019-5544/): VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2024-4947](https://insights.sbomify.com/CVE-2024-4947/): Google Chromium V8 Type Confusion (critical 9.6, exploited in the wild)
- [CVE-2024-4671](https://insights.sbomify.com/CVE-2024-4671/): Google Chromium Visuals Use-After-Free (critical 9.6, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-32760 and fix it if it is affected.

What it is: CVE-2021-32760 is a medium-severity vulnerability in Fedoraproject Fedora, published on 19 Jul 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2021-32760 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/containerd/containerd (Go): affected all versions; fixed in 1.4.8, 1.5.4
- github.com/containerd/containerd (Go): affected all versions; fixed in 1.4.8
- github.com/containerd/containerd (Go): affected all versions; fixed in 1.4.8
- github.com/containerd/containerd (Go): affected from 1.5.0; fixed in 1.5.4
- github.com/containerd/containerd (Go): affected from 1.5.0; fixed in 1.5.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-32760/ (Markdown: https://insights.sbomify.com/CVE-2021-32760/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-32760
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-32760
- OSV: https://osv.dev/vulnerability/CVE-2021-32760

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-32760/
Summaries are generated and may contain mistakes; the official description above is the record.
