# CVE-2021-32769: Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') in micronaut-core

> Attackers can read arbitrary files from the server filesystem via path traversal in Micronaut Core, requiring an upgrade to secure the application.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Jul 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-cjx7-399x-p2rj

## What is CVE-2021-32769?

CVE-2021-32769 is a high-severity path traversal vulnerability in micronaut-projects micronaut-core, published on 16 Jul 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Micronaut is a JVM-based, full stack Java framework designed for building JVM applications. A path traversal vulnerability exists in versions prior to 2.5.9. With a basic configuration, it is possible to access any file from a filesystem, using "/../../" in the URL. This occurs because Micronaut does not restrict file access to configured paths. The vulnerability is patched in version 2.5.9. As a workaround, do not use `**` in mapping, use only `*`, which exposes only flat structure of a directory not allowing traversal. If using Linux, another workaround is to run micronaut in chroot.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2021-32769?

2 open source packages ship an affected version, including io.micronaut:micronaut-http-server-netty. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `io.micronaut:micronaut-http-server-netty` | Maven | All versions | 2.5.9 |
| `io.micronaut:micronaut-http-server-netty` | Maven | All versions | 2.5.9 |

Products: Objectcomputing Micronaut.

## How do I fix CVE-2021-32769?

Upgrade io.micronaut:micronaut-http-server-netty to 2.5.9 or later.

## Is CVE-2021-32769 being exploited?

There is no known exploitation of CVE-2021-32769 in the wild and no public exploit code.

## Other vulnerabilities in micronaut-projects micronaut-core

- [CVE-2020-7611](https://insights.sbomify.com/CVE-2020-7611/): Micronaut's HTTP client is vulnerable to HTTP Request Header Injection (critical 9.8)
- [CVE-2026-33013](https://insights.sbomify.com/CVE-2026-33013/): Micronaut vulnerable to DoS via crafted form-urlencoded body binding with descending array indices (high 8.2)
- [CVE-2026-33012](https://insights.sbomify.com/CVE-2026-33012/): Micronaut Framework vulnerable to a Denial of Service in HTML error response caching (high 7.5)
- [CVE-2022-21700](https://insights.sbomify.com/CVE-2022-21700/): Memory leak in micronaut-core (medium 5.3)
- [CVE-2024-23639](https://insights.sbomify.com/CVE-2024-23639/): micronaut-core management endpoints vulnerable to drive-by localhost attack (medium 5.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-32769 and fix it if it is affected.

What it is: CVE-2021-32769 is a high-severity path traversal vulnerability in micronaut-projects micronaut-core, published on 16 Jul 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-32769 in the wild and no public exploit code.

Affected packages and fixed versions:
- io.micronaut:micronaut-http-server-netty (Maven): affected all versions; fixed in 2.5.9
- io.micronaut:micronaut-http-server-netty (Maven): affected all versions; fixed in 2.5.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-32769/ (Markdown: https://insights.sbomify.com/CVE-2021-32769/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-32769
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-32769
- OSV: https://osv.dev/vulnerability/CVE-2021-32769

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-32769/
Summaries are generated and may contain mistakes; the official description above is the record.
