# CVE-2021-32770: Basic-auth app bundle credential exposure in gatsby-source-wordpress

> The gatsby-source-wordpress plugin leaks HTTP Basic Authentication credentials into the client-side bundle when configured, exposing sensitive data to attackers.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Jul 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-rqjw-p5vr-c695

## What is CVE-2021-32770?

CVE-2021-32770 is a high-severity vulnerability in gatsbyjs gatsby, published on 15 Jul 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Gatsby is a framework for building websites. The gatsby-source-wordpress plugin prior to versions 4.0.8 and 5.9.2 leaks .htaccess HTTP Basic Authentication variables into the app.js bundle during build-time. Users who are not initializing basic authentication credentials in the gatsby-config.js are not affected. A patch has been introduced in gatsby-source-wordpress@4.0.8 and gatsby-source-wordpress@5.9.2 which mitigates the issue by filtering all variables specified in the `auth: { }` section. Users that depend on this functionality are advised to upgrade to the latest release of gatsby-source-wordpress, run `gatsby clean` followed by a `gatsby build`. One may manually edit the app.js file post-build as a workaround.

Weakness: CWE-522 (Insufficiently Protected Credentials), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2021-32770?

4 open source packages ship an affected version, including gatsby-source-wordpress. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `gatsby-source-wordpress` | npm | All versions | 4.0.8 |
| `gatsby-source-wordpress` | npm | All versions | 4.0.8 |
| `gatsby-source-wordpress` | npm | From 5.0.0 | 5.9.2 |
| `gatsby-source-wordpress` | npm | From 5.0.0 | 5.9.2 |

Products: Gatsbyjs Gatsby-Source-Wordpress.

## How do I fix CVE-2021-32770?

Upgrade gatsby-source-wordpress to a fixed version for your release line: 4.0.8 or 5.9.2.

## Is CVE-2021-32770 being exploited?

There is no known exploitation of CVE-2021-32770 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-32770 and fix it if it is affected.

What it is: CVE-2021-32770 is a high-severity vulnerability in gatsbyjs gatsby, published on 15 Jul 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-32770 in the wild and no public exploit code.

Affected packages and fixed versions:
- gatsby-source-wordpress (npm): affected all versions; fixed in 4.0.8
- gatsby-source-wordpress (npm): affected all versions; fixed in 4.0.8
- gatsby-source-wordpress (npm): affected from 5.0.0; fixed in 5.9.2
- gatsby-source-wordpress (npm): affected from 5.0.0; fixed in 5.9.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-32770/ (Markdown: https://insights.sbomify.com/CVE-2021-32770/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-32770
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-32770
- OSV: https://osv.dev/vulnerability/CVE-2021-32770

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-32770/
Summaries are generated and may contain mistakes; the official description above is the record.
