# CVE-2021-32772: Improper Neutralization of Special Elements used in an OS Command ('OS Command Injection') in helper_entries

> An attacker can execute arbitrary commands on the client machine by injecting malicious code into podcast feed data in Poddycast.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 3 Aug 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-wjmh-9fj2-rqh6

## What is CVE-2021-32772?

CVE-2021-32772 is a high-severity code injection vulnerability in MrChuckomo poddycast, published on 3 Aug 2021. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Poddycast is a podcast app made with Electron. Prior to version 0.8.1, an attacker can create a podcast or episode with malicious characters and execute commands on the client machine. The application does not clean the HTML characters of the podcast information obtained from the Feed, which allows the injection of HTML and JS code (cross-site scripting). Being an application made in electron, cross-site scripting can be scaled to remote code execution, making it possible to execute commands on the machine where the application is running. The vulnerability is patched in Poddycast version 0.8.1.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation), CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2021-32772?

It affects 1 product.


Products: Electronjs Poddycast.

## How do I fix CVE-2021-32772?

No fix has been published for CVE-2021-32772 yet. Limit exposure of the affected software until one is available.

## Is CVE-2021-32772 being exploited?

There is no known exploitation of CVE-2021-32772 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-32772 and fix it if it is affected.

What it is: CVE-2021-32772 is a high-severity code injection vulnerability in MrChuckomo poddycast, published on 3 Aug 2021. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-32772 in the wild and no public exploit code.

Affected product: MrChuckomo poddycast. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-32772/ (Markdown: https://insights.sbomify.com/CVE-2021-32772/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-32772
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-32772
- OSV: https://osv.dev/vulnerability/CVE-2021-32772

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-32772/
Summaries are generated and may contain mistakes; the official description above is the record.
