# CVE-2021-32779: Incorrectly handling of URI '#fragment' element as part of the path element

> Attackers can bypass path-based authorization rules by using URI fragments, potentially escalating privileges in Envoy proxy deployments.

- **Severity:** High 8.6 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Aug 2021
- **Updated:** 3 Aug 2024
- **Also known as:** BIT-envoy-2021-32779, GHSA-r222-74fw-jqr9

## What is CVE-2021-32779?

CVE-2021-32779 is a high-severity authentication bypass vulnerability in Envoyproxy Envoy, published on 24 Aug 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Envoy is an open source L7 proxy and communication bus designed for large modern service oriented architectures. In affected versions envoy incorrectly handled a URI '#fragment' element as part of the path element. Envoy is configured with an RBAC filter for authorization or similar mechanism with an explicit case of a final "/admin" path element, or is using a negative assertion with final path element of "/admin". The client sends request to "/app1/admin#foo". In Envoy prior to 1.18.0, or 1.18.0+ configured with path_normalization=false. Envoy treats fragment as a suffix of the query string when present, or as a suffix of the path when query string is absent, so it evaluates the final path element as "/admin#foo" and mismatches with the configured "/admin" path element. In Envoy 1.18.0+ configured with path_normalization=true. Envoy transforms this to /app1/admin%23foo and mismatches with the configured /admin prefix. The resulting URI is sent to the next server-agent with the offending "#foo" fragment which violates RFC3986 or with the nonsensical "%23foo" text appended. A specifically constructed request with URI containing '#fragment' element delivered by an untrusted client in the presence of path based request authorization resulting in escalation of Privileges when path based request authorization extensions. Envoy versions 1.19.1, 1.18.4, 1.17.4, 1.16.5 contain fixes that removes fragment from URI path in incoming requests.

Weakness: CWE-697 (Incorrect Comparison), CWE-863 (Incorrect Authorization), CWE-551 (Incorrect Behavior Order: Authorization Before Parsing and Canonicalization)

## Which versions are affected by CVE-2021-32779?

1 open source package ship an affected version, including envoy. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `envoy` | Bitnami | From 1.16.0 | 1.16.5, 1.17.4, 1.18.4, 1.19.1 |

Products: Envoyproxy Envoy.

## How do I fix CVE-2021-32779?

Upgrade envoy to a fixed version for your release line: 1.16.5, 1.17.4, 1.18.4 or 1.19.1.

## Is CVE-2021-32779 being exploited?

There is no known exploitation of CVE-2021-32779 in the wild and no public exploit code.

## Other vulnerabilities in Envoyproxy Envoy

- [CVE-2022-29226](https://insights.sbomify.com/CVE-2022-29226/): Trivial authentication bypass in Envoy (critical 10.0)
- [CVE-2019-18801](https://insights.sbomify.com/CVE-2019-18801/): Memory corruption in n/a (critical 9.8)
- [CVE-2019-18802](https://insights.sbomify.com/CVE-2019-18802/): Security feature bypass in n/a (critical 9.8)
- [CVE-2020-35470](https://insights.sbomify.com/CVE-2020-35470/): Information disclosure in n/a (high 8.8)
- [CVE-2024-23324](https://insights.sbomify.com/CVE-2024-23324/): Envoy ext auth can be bypassed when Proxy protocol filter sets invalid UTF-8 metadata (high 8.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-32779 and fix it if it is affected.

What it is: CVE-2021-32779 is a high-severity authentication bypass vulnerability in Envoyproxy Envoy, published on 24 Aug 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-32779 in the wild and no public exploit code.

Affected packages and fixed versions:
- envoy (Bitnami): affected from 1.16.0; fixed in 1.16.5, 1.17.4, 1.18.4, 1.19.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-32779/ (Markdown: https://insights.sbomify.com/CVE-2021-32779/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-32779
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-32779
- OSV: https://osv.dev/vulnerability/CVE-2021-32779

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-32779/
Summaries are generated and may contain mistakes; the official description above is the record.
