CVE-2021-32783 Authorization bypass in Contour
Attackers can bypass authorization to access Envoy admin interface, causing denial of service or exposing secret metadata in Contour.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2021-32783?
CVE-2021-32783 is a high-severity authentication bypass vulnerability in projectcontour contour, published on 23 Jul 2021. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Contour is a Kubernetes ingress controller using Envoy proxy. In Contour before version 1.17.1 a specially crafted ExternalName type Service may be used to access Envoy's admin interface, which Contour normally prevents from access outside the Envoy container. This can be used to shut down Envoy remotely (a denial of service), or to expose the existence of any Secret that Envoy is using for its configuration, including most notably TLS Keypairs. However, it *cannot* be used to get the *content* of those secrets. Since this attack allows access to the administration interface, a variety of administration options are available, such as shutting down the Envoy or draining traffic. In general, the Envoy admin interface cannot easily be used for making changes to the cluster, in-flight requests, or backend services, but it could be used to shut down or drain Envoy, change traffic routing, or to retrieve secret metadata, as mentioned above. The issue will be addressed in Contour v1.18.0 and a cherry-picked patch release, v1.17.1, has been released to cover users who cannot upgrade at this time. For more details refer to the linked GitHub Security Advisory.
Which versions are affected by CVE-2021-32783?
10 open source packages ship an affected version, including github.com/projectcontour/contour and contour. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/projectcontour/contour Go | All versions | 1.14.2, 1.15.2, 1.16.1, 1.17.1 |
github.com/projectcontour/contour Go | All versions | 1.14.2 |
github.com/projectcontour/contour Go | All versions | 1.14.2 |
github.com/projectcontour/contour Go | From 1.15.0 | 1.15.2 |
github.com/projectcontour/contour Go | From 1.15.0 | 1.15.2 |
github.com/projectcontour/contour Go | From 1.16.0 | 1.16.1 |
4 more packages
github.com/projectcontour/contour Go | From 1.16.0 | 1.16.1 |
github.com/projectcontour/contour Go | From 1.17.0 | 1.17.1 |
github.com/projectcontour/contour Go | From 1.17.0 | 1.17.1 |
contour Bitnami | All versions | 1.17.1 |
Products include Projectcontour Contour.
How do I fix CVE-2021-32783?
Upgrade github.com/projectcontour/contour to a fixed version for your release line: 1.14.2, 1.15.2, 1.16.1 or 1.17.1.
Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.
Is CVE-2021-32783 being exploited?
There is no known exploitation of CVE-2021-32783 in the wild and no public exploit code.
Other vulnerabilities in projectcontour contour
Sources
Also known as BIT-contour-2021-32783, GHSA-5ph6-qq5x-7jwc, GO-2022-0922.