# CVE-2021-32788: Post creator of a whisper post can be revealed to non-staff users in Discourse

> Attackers can reveal the identity of whisper post creators to non-staff users, exposing private user information in Discourse forums.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Jul 2021
- **Updated:** 3 Aug 2024
- **Also known as:** BIT-discourse-2021-32788, GHSA-v6xg-q577-vc92

## What is CVE-2021-32788?

CVE-2021-32788 is a medium-severity vulnerability in Discourse Discourse, published on 27 Jul 2021. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Discourse is an open source discussion platform. In versions prior to 2.7.7 there are two bugs which led to the post creator of a whisper post being revealed to non-staff users. 1: Staff users that creates a whisper post in a personal message is revealed to non-staff participants of the personal message even though the whisper post cannot be seen by them. 2: When a whisper post is before the last post in a post stream, deleting the last post will result in the creator of the whisper post to be revealed to non-staff users as the last poster of the topic.

Weakness: CWE-668 (Exposure of Resource to Wrong Sphere)

## Which versions are affected by CVE-2021-32788?

1 open source package ship an affected version, including discourse. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `discourse` | Bitnami | All versions | 2.7.7 |

Products: Discourse Discourse.

## How do I fix CVE-2021-32788?

Upgrade discourse to 2.7.7 or later.

## Is CVE-2021-32788 being exploited?

There is no known exploitation of CVE-2021-32788 in the wild and no public exploit code.

## Other vulnerabilities in Discourse Discourse

- [CVE-2021-41163](https://insights.sbomify.com/CVE-2021-41163/): RCE via malicious SNS subscription payload (critical 10.0)
- [CVE-2022-36066](https://insights.sbomify.com/CVE-2022-36066/): Discourse vulnerable to RCE via admins uploading maliciously zipped file (critical 9.1)
- [CVE-2022-39356](https://insights.sbomify.com/CVE-2022-39356/): Discourse user account takeover via email and invite link (high 8.9)
- [CVE-2023-22468](https://insights.sbomify.com/CVE-2023-22468/): Discourse vulnerable to Cross-site Scripting in local oneboxes (high 8.8)
- [CVE-2026-27934](https://insights.sbomify.com/CVE-2026-27934/): Discourse leaks private topic title and post excerpt via user action API endpoint (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-32788 and fix it if it is affected.

What it is: CVE-2021-32788 is a medium-severity vulnerability in Discourse Discourse, published on 27 Jul 2021. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-32788 in the wild and no public exploit code.

Affected packages and fixed versions:
- discourse (Bitnami): affected all versions; fixed in 2.7.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-32788/ (Markdown: https://insights.sbomify.com/CVE-2021-32788/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-32788
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-32788
- OSV: https://osv.dev/vulnerability/CVE-2021-32788

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-32788/
Summaries are generated and may contain mistakes; the official description above is the record.
