# CVE-2021-32796: Misinterpretation of malicious XML input in xmldom

> Attackers can cause unexpected syntactic changes in XML processing by exploiting improper escaping of special characters in xmldom.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Jul 2021
- **Updated:** 3 Aug 2024
- **Also known as:** DEBIAN-CVE-2021-32796, GHSA-5fg8-2547-mr8q, UBUNTU-CVE-2021-32796

## What is CVE-2021-32796?

CVE-2021-32796 is a medium-severity vulnerability in xmldom, published on 27 Jul 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

xmldom is an open source pure JavaScript W3C standard-based (XML DOM Level 2 Core) DOMParser and XMLSerializer module. xmldom versions 0.6.0 and older do not correctly escape special characters when serializing elements removed from their ancestor. This may lead to unexpected syntactic changes during XML processing in some downstream applications. This issue has been resolved in version 0.7.0. As a workaround downstream applications can validate the input and reject the maliciously crafted documents.

Weakness: CWE-91 (XML Injection), CWE-116 (Improper Encoding or Escaping of Output)

## Which versions are affected by CVE-2021-32796?

4 open source packages ship an affected version, including @xmldom/xmldom and xmldom. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@xmldom/xmldom` | npm | All versions | 0.7.0 |
| `@xmldom/xmldom` | npm | All versions | 0.7.0 |
| `xmldom` | npm | All versions to 0.6.0 | None |
| `xmldom` | npm | All versions to 0.6.0 | None |

Products: Xmldom Project Xmldom.

## How do I fix CVE-2021-32796?

Upgrade @xmldom/xmldom to 0.7.0 or later.

## Is CVE-2021-32796 being exploited?

There is no known exploitation of CVE-2021-32796 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-32796 and fix it if it is affected.

What it is: CVE-2021-32796 is a medium-severity vulnerability in xmldom, published on 27 Jul 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-32796 in the wild and no public exploit code.

Affected packages and fixed versions:
- @xmldom/xmldom (npm): affected all versions; fixed in 0.7.0
- @xmldom/xmldom (npm): affected all versions; fixed in 0.7.0
- xmldom (npm): affected all versions up to 0.6.0; no fix listed
- xmldom (npm): affected all versions up to 0.6.0; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-32796/ (Markdown: https://insights.sbomify.com/CVE-2021-32796/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-32796
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-32796
- OSV: https://osv.dev/vulnerability/CVE-2021-32796

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-32796/
Summaries are generated and may contain mistakes; the official description above is the record.
