CVE-2021-32803 Arbitrary File Creation/Overwrite via insufficient symlink protection due to directory cache poisoning
Attackers can bypass symlink protections in node-tar to create or overwrite arbitrary files, potentially leading to code execution.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Local or same network only
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2021-32803?
CVE-2021-32803 is a high-severity path traversal vulnerability in Oracle Graalvm, published on 3 Aug 2021. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Official description
The npm package "tar" (aka node-tar) before versions 6.1.2, 5.0.7, 4.4.15, and 3.2.3 has an arbitrary File Creation/Overwrite vulnerability via insufficient symlink protection. `node-tar` aims to guarantee that any file whose location would be modified by a symbolic link is not extracted. This is, in part, achieved by ensuring that extracted directories are not symlinks. Additionally, in order to prevent unnecessary `stat` calls to determine whether a given path is a directory, paths are cached when directories are created. This logic was insufficient when extracting tar files that contained both a directory and a symlink with the same name as the directory. This order of operations resulted in the directory being created and added to the `node-tar` directory cache. When a directory is present in the directory cache, subsequent calls to mkdir for that directory are skipped. However, this is also where `node-tar` checks for symlinks occur. By first creating a directory, and then replacing that directory with a symlink, it was thus possible to bypass `node-tar` symlink checks on directories, essentially allowing an untrusted tar file to symlink into an arbitrary location and subsequently extracting arbitrary files into that location, thus allowing arbitrary file creation and overwrite. This issue was addressed in releases 3.2.3, 4.4.15, 5.0.7 and 6.1.2.
Which versions are affected by CVE-2021-32803?
8 open source packages ship an affected version, including tar. It affects 3 products.
| Package | Affected | Fixed in |
|---|---|---|
tar npm | From 3.0.0 | 3.2.3 |
tar npm | From 3.0.0 | 3.2.3 |
tar npm | From 4.0.0 | 4.4.15 |
tar npm | From 4.0.0 | 4.4.15 |
tar npm | From 5.0.0 | 5.0.7 |
tar npm | From 5.0.0 | 5.0.7 |
2 more packages
tar npm | From 6.0.0 | 6.1.2 |
tar npm | From 6.0.0 | 6.1.2 |
Products include Oracle Graalvm, Siemens Sinec Infrastructure Network Services, Tar Project Tar.
How do I fix CVE-2021-32803?
Upgrade tar to a fixed version for your release line: 3.2.3, 4.4.15, 5.0.7 or 6.1.2.
Upgrade, and resolve every user-supplied path against an allowed base folder before opening it. More about Path traversal.
Is CVE-2021-32803 being exploited?
There is no known exploitation of CVE-2021-32803 in the wild and no public exploit code.
Other vulnerabilities in Oracle Graalvm
- CVE-2025-50059 Security feature bypass in Oracle GraalVM Enterprise Edition
- CVE-2021-32804 Arbitrary File Creation/Overwrite due to insufficient absolute path sanitization
- CVE-2025-30749 Code injection in Oracle GraalVM Enterprise Edition
- CVE-2025-50106 Code injection in Oracle GraalVM Enterprise Edition
- CVE-2026-62574 Privilege escalation in Oracle GraalVM Enterprise Edition
Sources
Also known as CLSA-2026-1775176089, CLSA-2026-1792164455, DEBIAN-CVE-2021-32803, GHSA-r628-mhmh-qjhw, ROOT-APP-NPM-CVE-2021-32803, UBUNTU-CVE-2021-32803 and 1 more.