CVE-2021-32804 Arbitrary File Creation/Overwrite due to insufficient absolute path sanitization
Attackers can overwrite arbitrary files via crafted tar archives with repeated path roots, potentially leading to code execution.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Local or same network only
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2021-32804?
CVE-2021-32804 is a high-severity path traversal vulnerability in Oracle Graalvm, published on 3 Aug 2021. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Official description
The npm package "tar" (aka node-tar) before versions 6.1.1, 5.0.6, 4.4.14, and 3.3.2 has a arbitrary File Creation/Overwrite vulnerability due to insufficient absolute path sanitization. node-tar aims to prevent extraction of absolute file paths by turning absolute paths into relative paths when the `preservePaths` flag is not set to `true`. This is achieved by stripping the absolute path root from any absolute file paths contained in a tar file. For example `/home/user/.bashrc` would turn into `home/user/.bashrc`. This logic was insufficient when file paths contained repeated path roots such as `////home/user/.bashrc`. `node-tar` would only strip a single path root from such paths. When given an absolute file path with repeating path roots, the resulting path (e.g. `///home/user/.bashrc`) would still resolve to an absolute path, thus allowing arbitrary file creation and overwrite. This issue was addressed in releases 3.2.2, 4.4.14, 5.0.6 and 6.1.1. Users may work around this vulnerability without upgrading by creating a custom `onentry` method which sanitizes the `entry.path` or a `filter` method which removes entries with absolute paths. See referenced GitHub Advisory for details. Be aware of CVE-2021-32803 which fixes a similar bug in later versions of tar.
Weakness: CWE-22
Which versions are affected by CVE-2021-32804?
8 open source packages ship an affected version, including tar. It affects 3 products.
| Package | Affected | Fixed in |
|---|---|---|
tar npm | All versions | 3.2.2 |
tar npm | All versions | 3.2.2 |
tar npm | From 4.0.0 | 4.4.14 |
tar npm | From 4.0.0 | 4.4.14 |
tar npm | From 5.0.0 | 5.0.6 |
tar npm | From 5.0.0 | 5.0.6 |
2 more packages
tar npm | From 6.0.0 | 6.1.1 |
tar npm | From 6.0.0 | 6.1.1 |
Products include Oracle Graalvm, Siemens Sinec Infrastructure Network Services, Tar Project Tar.
How do I fix CVE-2021-32804?
Upgrade tar to a fixed version for your release line: 3.2.2, 4.4.14, 5.0.6 or 6.1.1.
Upgrade, and resolve every user-supplied path against an allowed base folder before opening it. More about Path traversal.
Is CVE-2021-32804 being exploited?
There is no known exploitation of CVE-2021-32804 in the wild and no public exploit code.
Public exploit code: 1 proofs of concept on GitHub.
Other vulnerabilities in Oracle Graalvm
- CVE-2025-50059 Security feature bypass in Oracle GraalVM Enterprise Edition
- CVE-2021-32803 Arbitrary File Creation/Overwrite via insufficient symlink protection due to directory cache poisoning
- CVE-2025-30749 Code injection in Oracle GraalVM Enterprise Edition
- CVE-2025-50106 Code injection in Oracle GraalVM Enterprise Edition
- CVE-2026-62574 Privilege escalation in Oracle GraalVM Enterprise Edition
Sources
Also known as CLSA-2026-1775176096, CLSA-2026-1777941831, DEBIAN-CVE-2021-32804, GHSA-3jfq-g458-7qm9, ROOT-APP-NPM-CVE-2021-32804, UBUNTU-CVE-2021-32804.