# CVE-2021-32808: Cross-site scripting in ckeditor via abuse of undo functionality

> Attackers can execute JavaScript via malformed widget HTML in CKEditor 4 when the clipboard Widget and undo plugins are enabled.

- **Severity:** High 7.6 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 12 Aug 2021
- **Updated:** 3 Aug 2024
- **Also known as:** DEBIAN-CVE-2021-32808, GHSA-6226-h7ff-ch6c

## What is CVE-2021-32808?

CVE-2021-32808 is a high-severity cross-site scripting vulnerability in Fedoraproject Fedora, published on 12 Aug 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

ckeditor is an open source WYSIWYG HTML editor with rich content support. A vulnerability has been discovered in the clipboard Widget plugin if used alongside the undo feature. The vulnerability allows a user to abuse undo functionality using malformed widget HTML, which could result in executing JavaScript code. It affects all users using the CKEditor 4 plugins listed above at version >= 4.13.0. The problem has been recognized and patched. The fix will be available in version 4.16.2.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2021-32808?

2 open source packages ship an affected version, including ckeditor4. It affects 13 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ckeditor4` | npm | From 4.13.0 | 4.16.2 |
| `ckeditor4` | npm | From 4.13.0 | 4.16.2 |

Products: Ckeditor Ckeditor, Fedoraproject Fedora, Oracle Application Express, Oracle Banking Party Management, Oracle Commerce Guided Search, Oracle Commerce Merchandising, Oracle Documaker, Oracle Financial Services Analytical Applications Infrastructure, Oracle Financial Services Model Management and Governance, Oracle Jd Edwards Enterpriseone Tools, Oracle Peoplesoft Enterprise Peopletools, Oracle Siebel Ui Framework, Oracle Webcenter Sites.

## How do I fix CVE-2021-32808?

Upgrade ckeditor4 to 4.16.2 or later.

## Is CVE-2021-32808 being exploited?

There is no known exploitation of CVE-2021-32808 in the wild and no public exploit code.

## Other vulnerabilities in Fedoraproject Fedora

- [CVE-2023-31541](https://insights.sbomify.com/CVE-2023-31541/): File upload in n/a (critical 9.8)
- [CVE-2021-41164](https://insights.sbomify.com/CVE-2021-41164/): Advanced Content Filter (ACF) vulnerability allowing to execute JavaScript code using malformed HTML (high 8.2)
- [CVE-2021-41165](https://insights.sbomify.com/CVE-2021-41165/): HTML comments vulnerability allowing to execute JavaScript code (high 8.2)
- [CVE-2011-4972](https://insights.sbomify.com/CVE-2011-4972/): Missing authorization in CKEditor Drupal module (high 7.5)
- [CVE-2021-37695](https://insights.sbomify.com/CVE-2021-37695/): Execution of JavaScript code using malformed HTML in ckeditor (high 7.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-32808 and fix it if it is affected.

What it is: CVE-2021-32808 is a high-severity cross-site scripting vulnerability in Fedoraproject Fedora, published on 12 Aug 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2021-32808 in the wild and no public exploit code.

Affected packages and fixed versions:
- ckeditor4 (npm): affected from 4.13.0; fixed in 4.16.2
- ckeditor4 (npm): affected from 4.13.0; fixed in 4.16.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-32808/ (Markdown: https://insights.sbomify.com/CVE-2021-32808/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-32808
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-32808
- OSV: https://osv.dev/vulnerability/CVE-2021-32808

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-32808/
Summaries are generated and may contain mistakes; the official description above is the record.
